summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog16
-rw-r--r--debian/compat1
-rw-r--r--debian/control11
-rwxr-xr-xdebian/rules12
4 files changed, 29 insertions, 11 deletions
diff --git a/debian/changelog b/debian/changelog
index 98e4ceb1..f3f9d4f3 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,17 @@
+tome (2.4.0-ah-1) unstable; urgency=medium
+
+ * New upstream version
+ * Update the VCS-* fields in the control file to point to salsa
+ * Update standards version to 4.3.0. No changes needed
+ * The GTK frontend is back.
+ * Bug fix: "duplicate files: README.Debian", thanks to IOhannes m
+ zmoelnig (Closes: #864346).
+ * Bug fix: "FTBFS on hurd-i386: PATH_MAX undeclared", thanks to Aaron
+ M. Ucko (Closes: #875774). Added the same max as from
+ /usr/include/linux/limits.h
+
+ -- Manoj Srivastava <srivasta@debian.org> Fri, 22 May 2020 22:03:47 -0700
+
tome (2.4~0.git.2015.12.29-1.2) unstable; urgency=medium
* Non-maintainer upload.
@@ -7,7 +21,7 @@ tome (2.4~0.git.2015.12.29-1.2) unstable; urgency=medium
that support these.
[ Bhavani Shankar ]
- * Match variable boolean type in z-rand.cc to fix compilation on
+ * Match variable boolean type in z-rand.cc to fix compilation on
32 bit archs. Thanks to Andreas Beckmann from debian for the
report. Closes: #843984.
diff --git a/debian/compat b/debian/compat
deleted file mode 100644
index ec635144..00000000
--- a/debian/compat
+++ /dev/null
@@ -1 +0,0 @@
-9
diff --git a/debian/control b/debian/control
index 2cf18ebb..bc75f59c 100644
--- a/debian/control
+++ b/debian/control
@@ -1,15 +1,16 @@
Source: tome
-VCS-Git: https://anonscm.debian.org/git/users/srivasta/debian/tome.git
-VCS-Browser: https://anonscm.debian.org/gitweb/?p=users/srivasta/debian/tome.git;a=summary
+VCS-Git: https://salsa.debian.org/srivasta/tome.git
+VCS-Browser: https://salsa.debian.org/srivasta/tome
Section: non-free/games
Priority: optional
Maintainer: Manoj Srivastava <srivasta@debian.org>
Homepage: https://github.com/tome2/tome2
-Build-Depends: debhelper (>= 9.0.0), libjansson-dev, cmake,
+Build-Depends: debhelper-compat (= 12), libjansson-dev, cmake,
libncurses5-dev | libncurses-dev | ncurses-dev, libboost-all-dev,
- libsdl-image1.2-dev, libsdl-ttf2.0-dev, libx11-dev, dpkg-dev (>= 1.16.0)
-Standards-Version: 3.9.6
+ libsdl-image1.2-dev, libsdl-ttf2.0-dev, libx11-dev, libgtk2.0-dev,
+ dpkg-dev (>= 1.16.0)
XS-Autobuild: yes
+Standards-Version: 4.3.0
Package: tome
Architecture: any
diff --git a/debian/rules b/debian/rules
index 6abd12de..2e01676a 100755
--- a/debian/rules
+++ b/debian/rules
@@ -43,8 +43,8 @@ ifneq (,$(filter amd64 arm64 armel armhf i386 powerpc ppc64 ppc64el x32 sparc sp
# Upstream passes these unconditionally, but they're only available on
# certain architectures.
CONFIGURE_ARGS += \
- -DCMAKE_C_FLAGS="-fsanitize=undefined -fsanitize=address" \
- -DCMAKE_CXX_FLAGS="-fsanitize=undefined -fsanitize=address"
+ -DCMAKE_C_FLAGS_DEBUG="${SANITIZER_FLAGS}" \
+ -DCMAKE_CXX_FLAGS_DEBUG="${SANITIZER_FLAGS}"
endif
%:
@@ -80,9 +80,9 @@ override_dh_install:
override_dh_fixperms:
dh_fixperms
chgrp -R games $(TMPTOP)/etc/$(package)/* $(PKG_STATLIB)/* $(PKG_LIBDIR) \
- $(TMPTOP)/usr/games/tome
+ $(TMPTOP)/var/games/tome
chmod g+ws $(PKG_LIBDIR)/data/
- chmod g+s $(TMPTOP)/usr/games/tome
+ chmod g+s $(TMPTOP)/var/games/tome
override_dh_clean:
dh_clean
@@ -91,6 +91,10 @@ override_dh_clean:
touch ./lib/info/delete.me
touch ./lib/save/delete.me
touch ./lib/user/delete.me
+ test ! -e ${SRCTOP}/CMakeCache.txt || rm -f ${SRCTOP}/CMakeCache.txt
+ test ! -e ${SRCTOP}/Ccmake_install.cmake || rm -f ${SRCTOP}/cmake_install.cmake
+ test ! -e ${SRCTOP}/mAKEFILE || rm -f ${SRCTOP}/mAKEFILE
+ test ! -d ${SRCTOP}/CMakeFiles || rm -f ${SRCTOP}/CMakeFiles/
#Local variables:
#mode: makefile