summaryrefslogtreecommitdiff
path: root/src/notes.cc
diff options
context:
space:
mode:
Diffstat (limited to 'src/notes.cc')
-rw-r--r--src/notes.cc3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/notes.cc b/src/notes.cc
index 326381c9..69269291 100644
--- a/src/notes.cc
+++ b/src/notes.cc
@@ -129,9 +129,10 @@ void add_note_type(int note_number)
char player[100];
/* Build the string containing the player information */
+ auto const player_race_name = get_player_race_name(p_ptr->prace, p_ptr->pracem);
sprintf(player,
"the %s %s",
- get_player_race_name(p_ptr->prace, p_ptr->pracem),
+ player_race_name.c_str(),
class_info[p_ptr->pclass].spec[p_ptr->pspec].title);
/* Add in "character start" information */