summaryrefslogtreecommitdiff
path: root/src/xtra2.c
diff options
context:
space:
mode:
Diffstat (limited to 'src/xtra2.c')
-rw-r--r--src/xtra2.c18
1 files changed, 0 insertions, 18 deletions
diff --git a/src/xtra2.c b/src/xtra2.c
index 45a0caec..34a2a283 100644
--- a/src/xtra2.c
+++ b/src/xtra2.c
@@ -6066,24 +6066,6 @@ void corrupt_corrupted(void)
}
/*
- * Change to an other class
- */
-void switch_class(int sclass)
-{
- p_ptr->pclass = sclass;
- cp_ptr = &class_info[p_ptr->pclass];
-}
-
-/*
- * Change to an other subclass
- */
-void switch_subclass(int sclass)
-{
- p_ptr->pspec = sclass;
- spp_ptr = &class_info[p_ptr->pclass].spec[p_ptr->pspec];
-}
-
-/*
* Change to an other subrace
*/
void switch_subrace(int racem, bool_ copy_old)