summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
Diffstat (limited to 'src')
-rw-r--r--src/CMakeLists.txt1
-rw-r--r--src/plots.c3
-rw-r--r--src/plots.h3
-rw-r--r--src/q_narsil.c4
-rw-r--r--src/q_narsil.h13
-rw-r--r--src/tables.c1
6 files changed, 18 insertions, 7 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index bd706b04..8dc8c234 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -11,6 +11,7 @@ SET(SRCS
variable.c tables.c plots.c util.c cave.c dungeon.c
melee1.c melee2.c messages.c modules.c
q_god.c q_library.c q_fireprof.c q_bounty.c q_thrain.c
+ q_narsil.c
object1.c object2.c randart.c squeltch.cc traps.c
monster1.c monster2.c monster3.c
xtra1.c xtra2.c skills.c powers.c gods.c
diff --git a/src/plots.c b/src/plots.c
index db0d1096..19c6afcb 100644
--- a/src/plots.c
+++ b/src/plots.c
@@ -394,6 +394,3 @@ bool_ quest_null_hook(int q)
/************************* Khazad-dum plot ************************/
#include "q_evil.c"
-
-/*************************** Other plot ***************************/
-#include "q_narsil.c"
diff --git a/src/plots.h b/src/plots.h
index 7b2396ec..7c0b8b00 100644
--- a/src/plots.h
+++ b/src/plots.h
@@ -43,9 +43,6 @@ extern bool_ quest_between_init_hook(int q_idx);
/******* Plot Khazad-dum *********/
extern bool_ quest_evil_init_hook(int q_idx);
-/******* Plot Other *********/
-extern bool_ quest_narsil_init_hook(int q_idx);
-
/******* Plot God Quest **************/
extern bool_ quest_god_describe(FILE *);
extern bool_ quest_god_init_hook(int q);
diff --git a/src/q_narsil.c b/src/q_narsil.c
index 27ec218e..3fe8b19f 100644
--- a/src/q_narsil.c
+++ b/src/q_narsil.c
@@ -1,4 +1,6 @@
-#undef cquest
+#include "q_narsil.h"
+
+
#define cquest (quest[QUEST_NARSIL])
bool_ quest_narsil_move_hook(char *fmt)
diff --git a/src/q_narsil.h b/src/q_narsil.h
new file mode 100644
index 00000000..227c0db7
--- /dev/null
+++ b/src/q_narsil.h
@@ -0,0 +1,13 @@
+#pragma once
+
+#include "angband.h"
+
+#ifdef __cplusplus
+extern "C" {
+#endif
+
+bool_ quest_narsil_init_hook(int q_idx);
+
+#ifdef __cplusplus
+} // extern "C"
+#endif
diff --git a/src/tables.c b/src/tables.c
index a391e7d5..bd399994 100644
--- a/src/tables.c
+++ b/src/tables.c
@@ -15,6 +15,7 @@
#include "q_fireprof.h"
#include "q_bounty.h"
#include "q_thrain.h"
+#include "q_narsil.h"