summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
Diffstat (limited to 'src')
-rw-r--r--src/CMakeLists.txt1
-rw-r--r--src/plots.c1
-rw-r--r--src/plots.h1
-rw-r--r--src/q_nirna.c3
-rw-r--r--src/q_nirna.h13
-rw-r--r--src/tables.c1
6 files changed, 17 insertions, 3 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index c41f3019..69b57480 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -12,6 +12,7 @@ SET(SRCS
melee1.c melee2.c messages.c modules.c
q_god.c q_library.c q_fireprof.c q_bounty.c q_thrain.c
q_narsil.c q_evil.c q_betwen.c q_haunted.c q_invas.c
+ q_nirna.c
object1.c object2.c randart.c squeltch.cc traps.c
monster1.c monster2.c monster3.c
xtra1.c xtra2.c skills.c powers.c gods.c
diff --git a/src/plots.c b/src/plots.c
index 5cc0ef1c..2662d7d7 100644
--- a/src/plots.c
+++ b/src/plots.c
@@ -385,4 +385,3 @@ bool_ quest_null_hook(int q)
/************************** Gondolin plot *************************/
#include "q_dragons.c"
#include "q_eol.c"
-#include "q_nirna.c"
diff --git a/src/plots.h b/src/plots.h
index 737972a5..f8ac52a8 100644
--- a/src/plots.h
+++ b/src/plots.h
@@ -33,7 +33,6 @@ extern bool_ quest_poison_init_hook(int q_idx);
/******* Plot Gondolin *********/
extern bool_ quest_dragons_init_hook(int q_idx);
extern bool_ quest_eol_init_hook(int q_idx);
-extern bool_ quest_nirnaeth_init_hook(int q_idx);
/******* Plot God Quest **************/
extern bool_ quest_god_describe(FILE *);
diff --git a/src/q_nirna.c b/src/q_nirna.c
index be856d31..07991487 100644
--- a/src/q_nirna.c
+++ b/src/q_nirna.c
@@ -1,4 +1,5 @@
-#undef cquest
+#include "q_nirna.h"
+
#define cquest (quest[QUEST_NIRNAETH])
bool_ quest_nirnaeth_gen_hook(char *fmt)
diff --git a/src/q_nirna.h b/src/q_nirna.h
new file mode 100644
index 00000000..1c4a050b
--- /dev/null
+++ b/src/q_nirna.h
@@ -0,0 +1,13 @@
+#pragma once
+
+#include "angband.h"
+
+#ifdef __cplusplus
+extern "C" {
+#endif
+
+bool_ quest_nirnaeth_init_hook(int q_idx);
+
+#ifdef __cplusplus
+} // extern "C"
+#endif
diff --git a/src/tables.c b/src/tables.c
index b6bcb668..5f0f050f 100644
--- a/src/tables.c
+++ b/src/tables.c
@@ -20,6 +20,7 @@
#include "q_betwen.h"
#include "q_haunted.h"
#include "q_invas.h"
+#include "q_nirna.h"