summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
Diffstat (limited to 'src')
-rw-r--r--src/CMakeLists.txt2
-rw-r--r--src/plots.c3
-rw-r--r--src/plots.h3
-rw-r--r--src/q_wolves.c3
-rw-r--r--src/q_wolves.h13
-rw-r--r--src/tables.c1
6 files changed, 17 insertions, 8 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 15516dac..01281443 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -13,7 +13,7 @@ SET(SRCS
q_god.c q_library.c q_fireprof.c q_bounty.c q_thrain.c
q_narsil.c q_evil.c q_betwen.c q_haunted.c q_invas.c
q_nirna.c q_eol.c q_god.c q_dragons.c q_poison.c
- q_spider.c
+ q_spider.c q_wolves.c
object1.c object2.c randart.c squeltch.cc traps.c
monster1.c monster2.c monster3.c
xtra1.c xtra2.c skills.c powers.c gods.c
diff --git a/src/plots.c b/src/plots.c
index 45f2a87d..fabd118e 100644
--- a/src/plots.c
+++ b/src/plots.c
@@ -376,6 +376,3 @@ bool_ quest_null_hook(int q)
#include "q_wight.c"
#include "q_nazgul.c"
#include "q_shroom.c"
-
-/*************************** Lorien plot **************************/
-#include "q_wolves.c"
diff --git a/src/plots.h b/src/plots.h
index 40bdf4d8..41dcd087 100644
--- a/src/plots.h
+++ b/src/plots.h
@@ -24,6 +24,3 @@ extern bool_ quest_troll_init_hook(int q_idx);
extern bool_ quest_wight_init_hook(int q_idx);
extern bool_ quest_nazgul_init_hook(int q_idx);
extern bool_ quest_shroom_init_hook(int q_idx);
-
-/******* Plot Lorien *********/
-extern bool_ quest_wolves_init_hook(int q_idx);
diff --git a/src/q_wolves.c b/src/q_wolves.c
index 2ec14cc2..badbd319 100644
--- a/src/q_wolves.c
+++ b/src/q_wolves.c
@@ -1,4 +1,5 @@
-#undef cquest
+#include "q_wolves.h"
+
#define cquest (quest[QUEST_WOLVES])
bool_ quest_wolves_gen_hook(char *fmt)
diff --git a/src/q_wolves.h b/src/q_wolves.h
new file mode 100644
index 00000000..f006716f
--- /dev/null
+++ b/src/q_wolves.h
@@ -0,0 +1,13 @@
+#pragma once
+
+#include "angband.h"
+
+#ifdef __cplusplus
+extern "C" {
+#endif
+
+bool_ quest_wolves_init_hook(int q_idx);
+
+#ifdef __cplusplus
+} // extern "C"
+#endif
diff --git a/src/tables.c b/src/tables.c
index cc36f2f6..4a2c4b34 100644
--- a/src/tables.c
+++ b/src/tables.c
@@ -26,6 +26,7 @@
#include "q_dragons.h"
#include "q_poison.h"
#include "q_spider.h"
+#include "q_wolves.h"