summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
Diffstat (limited to 'src')
-rw-r--r--src/CMakeLists.txt2
-rw-r--r--src/config.h6
-rw-r--r--src/z-rand.cc2
3 files changed, 5 insertions, 5 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 942946fc..f4b2d2db 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -156,5 +156,5 @@ TARGET_LINK_LIBRARIES(harness game squelch ${LIBS})
# Installation
INSTALL(TARGETS tome
- RUNTIME DESTINATION bin
+ RUNTIME DESTINATION games
)
diff --git a/src/config.h b/src/config.h
index 290ec624..8ff00f8f 100644
--- a/src/config.h
+++ b/src/config.h
@@ -58,7 +58,7 @@
/*
* OPTION: Include "ncurses.h" instead of "curses.h" in "main-gcu.c"
*/
-/* #define USE_NCURSES */
+#define USE_NCURSES
@@ -92,7 +92,7 @@
* that file.
*/
#ifndef DEFAULT_PATH
-# define DEFAULT_PATH "./lib/"
+# define DEFAULT_PATH "/var/games/tome"
#endif
@@ -105,7 +105,7 @@
/*
* OPTION: Person to bother if something goes wrong.
*/
-#define MAINTAINER "darkgod@t-o-m-e.net"
+#define MAINTAINER "tome@packages.debian.org"
/*
diff --git a/src/z-rand.cc b/src/z-rand.cc
index c06b7893..e2960a55 100644
--- a/src/z-rand.cc
+++ b/src/z-rand.cc
@@ -351,7 +351,7 @@ s32b maxroll(s16b num, s16b sides)
return (num * sides);
}
-bool magik(int p) {
+bool magik(s32b p) {
return rand_int(100) < p;
}