summaryrefslogtreecommitdiff
path: root/vendor/bandit/specs/failure_formatters/default_formatter.spec.cpp
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/bandit/specs/failure_formatters/default_formatter.spec.cpp')
-rw-r--r--vendor/bandit/specs/failure_formatters/default_formatter.spec.cpp21
1 files changed, 21 insertions, 0 deletions
diff --git a/vendor/bandit/specs/failure_formatters/default_formatter.spec.cpp b/vendor/bandit/specs/failure_formatters/default_formatter.spec.cpp
new file mode 100644
index 00000000..6d29b694
--- /dev/null
+++ b/vendor/bandit/specs/failure_formatters/default_formatter.spec.cpp
@@ -0,0 +1,21 @@
+#include <specs/specs.h>
+namespace bd = bandit::detail;
+
+go_bandit([](){
+
+ describe("default failure formatter", [&](){
+ bd::default_failure_formatter formatter;
+
+ it("formats assertions with file and line number", [&](){
+ bd::assertion_exception exception("message", "file", 321);
+ AssertThat(formatter.format(exception), Equals("file:321: message"));
+ });
+
+ it("formats assertions without file and line number", [&](){
+ bd::assertion_exception exception("message");
+ AssertThat(formatter.format(exception), Equals("message"));
+ });
+
+ });
+
+});