summaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAge
...
| | * | Refactor lua_{msg,input}_box and renameBardur Arantsson2017-05-02
| | | |
| | * | Move player_{name,base} to GameBardur Arantsson2017-05-02
| | | |
| | * | Move "Game" initialization to main_real()Bardur Arantsson2017-05-02
| | | |
| | * | Remove random_spell::{name,desc}Bardur Arantsson2017-05-02
| | | |
| | * | Remove RunecraftingBardur Arantsson2017-02-28
| | | |
| | * | Remove long-obsolete Automatizer filesBardur Arantsson2017-02-28
| | | |
| | * | Fix link orderBardur Arantsson2017-01-14
| | | |
| | * | Remove unnecessary include in dungeon.hBardur Arantsson2017-01-14
| | | |
| | * | main-win: Remove parameter from play_game()Bardur Arantsson2017-01-14
| | | |
| | * | Bump to fmt-3.0.1Bardur Arantsson2017-01-04
| | | |
| | * | Remove obsolete 'cppformat' vendor codeBardur Arantsson2017-01-04
| | | |
| | * | Remove unused artifact_type::max_numBardur Arantsson2017-01-04
| | | |
| | * | Reduce length of "light radius" object description messageBardur Arantsson2016-12-22
| | | |
| | * | Fix off-by-one when renaming Automatizer ruleBardur Arantsson2016-12-22
| | | |
| | * | Remove "adornment" amuletBardur Arantsson2016-12-22
| | | |
| | * | Rework compiler flagsBardur Arantsson2016-10-22
| | | | | | | | | | | | | | | | | | | | | | | | | | | | They're all currently identical for both GCC/Clang anyway. Move sanitizer flags to DEBUG-only configuration. Closes #8
| | * | Remove !SelfKnowledgeBardur Arantsson2016-10-22
| | | |
| | * | Fix monster spell selection caused by 'missing' TRAPS spellBardur Arantsson2016-10-16
| | | |
| | * | Remove "defines.txt"Bardur Arantsson2016-10-16
| | | | | | | | | | | | | | | | | | | | | | | | | | | | It's a maintenance nightmare -- which all but guarantees that it won't be maintained -- and of very limited value anyway. It's also an annoyance when cleaning up code dealing with items.
| | * | Remove TR_SEARCH object flagBardur Arantsson2016-10-16
| | | | | | | | | | | | | | | | | | | | Since the removal of traps its only effect was diluting the list of flags "available" for randarts and sentient items.
| | * | Remove Sneakiness from the skills.txt helpBardur Arantsson2016-10-16
| | | |
| | * | De-duplicate code for curse-breakingBardur Arantsson2016-10-16
| | | |
| | * | Work around bad strchr() declarationBardur Arantsson2016-10-08
| | | | | | | | | | | | | | | | Fixes #11
| | * | Remove dead declarationsBardur Arantsson2016-10-08
| | | |
| | * | Remove unused tactic_info_type.to_disarm fieldBardur Arantsson2016-10-08
| | | |
| | * | Fix formatting of tactic_info tableBardur Arantsson2016-10-08
| | | |
| | * | Remove dead trap codeBardur Arantsson2016-10-08
| | | |
| | * | Remove more documentation mentions of trapsBardur Arantsson2016-10-08
| | | |
| | * | Remove tr_info.txtBardur Arantsson2016-10-08
| | | |
| | * | Remove disturb_detect optionBardur Arantsson2016-10-08
| | | | | | | | | | | | | | | | It serves no purpose now that traps are gone.
| | * | Remove unused parameter from disturb()Bardur Arantsson2016-10-08
| | | |
| | * | Remove traps from maps and levelsBardur Arantsson2016-10-08
| | | |
| | * | Fix debug item creation menuElmo Todurov2016-10-06
| | | |
| | * | Add Vim swap files to .gitignoreElmo Todurov2016-10-06
| | | |
| | * | Removed a spurious __cxx11Elmo Todurov2016-10-06
| | | |
| | * | Added missing #includesElmo Todurov2016-10-06
| | | |
| | * | Fixed reading character historyElmo Todurov2016-10-06
| | | |
| | * | Fix out-of-bounds accesses to set_infoBardur Arantsson2016-10-06
| | | |
| | * | Fix indentationBardur Arantsson2016-10-05
| | | |
| | * | Add missing 'static'Bardur Arantsson2016-10-05
| | | |
| | * | Update command.txt to account for trap removalBardur Arantsson2016-10-05
| | | |
| | * | Bring Theme/debug.txt up to date with the T2 oneBardur Arantsson2016-10-05
| | | |
| | * | Reduce #object_flag tiersBardur Arantsson2016-10-05
| | | |
| | * | Remove trapsBardur Arantsson2016-10-05
| | | | | | | | | | | | | | | | | | | | | | | | Credit goes mostly to "miramor" <danlev@norwoodlight.com> who did most of the actual work. I just did a few minor tweaks and fixes + rebased onto master.
| | * | Remove "allocate" member function from the x_info traitsBardur Arantsson2016-10-05
| | | |
| | * | Move t_info into GameEditDataBardur Arantsson2016-10-05
| | | |
| | * | Move e_info into GameEditDataBardur Arantsson2016-10-05
| | | |
| | * | Move a_info into GameEditDataBardur Arantsson2016-10-05
| | | |
| | * | Move k_info into GameEditDataBardur Arantsson2016-10-05
| | | |
| | * | Move f_info into GameEditDataBardur Arantsson2016-10-05
| | | |