summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMattia Rizzolo <mattia@debian.org>2017-03-31 01:40:48 +0200
committerMattia Rizzolo <mattia@debian.org>2017-03-31 01:40:48 +0200
commit40beef6ba968c3a13df95f2d48926934106d59ff (patch)
treef9561bc4c4758ea8fa7a3539efd1642c23d3018a
parenta6df768b695a42cf31c137e6522098d28db4df8c (diff)
Use dh-autoreconf to fix FTBFS on ppc64el and update config.{sub, guess} for new arches
Closes: #736887 Signed-off-by: Mattia Rizzolo <mattia@debian.org>
-rw-r--r--debian/control2
-rwxr-xr-xdebian/rules2
2 files changed, 3 insertions, 1 deletions
diff --git a/debian/control b/debian/control
index b596b6e..cf9b706 100644
--- a/debian/control
+++ b/debian/control
@@ -3,7 +3,7 @@ Section: net
Priority: optional
Maintainer: Robert Lemmen <robertle@semistable.com>
Build-Depends: debhelper (>= 7.0.0), libevent-dev (>= 0.7b), autoconf,
- libbsd-dev, autotools-dev
+ libbsd-dev, dh-autoreconf
Standards-Version: 3.9.4
Package: trickle
diff --git a/debian/rules b/debian/rules
index 695932b..3bf5311 100755
--- a/debian/rules
+++ b/debian/rules
@@ -7,6 +7,7 @@ LDFLAGS:=$(shell dpkg-buildflags --get LDFLAGS)
config.status: configure
dh_testdir
+ dh_autoreconf
CPPFLAGS="$(CPPFLAGS)" CFLAGS="$(CFLAGS)" CXXFLAGS="$(CXXFLAGS)" \
LDFLAGS="$(LDFLAGS)" ./configure --prefix=/usr \
--mandir=/usr/share/man --sysconfdir=/etc --with-pic
@@ -27,6 +28,7 @@ clean:
dh_testroot
rm -f build-arch-stamp
[ ! -f Makefile ] || $(MAKE) distclean
+ dh_autoreconf_clean
dh_clean
install: build