summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Bogatov <KAction@debian.org>2018-11-29 08:53:22 +0000
committerDmitry Bogatov <KAction@debian.org>2018-11-29 08:53:22 +0000
commitd1d904439ec2574254e667065c0660e98ba6c439 (patch)
tree8683ceeec8467631e592a2b0c546d4bbdbe8db07
parentccdf681e032c07dda0f2dc2686b0e7fdfea23664 (diff)
Respect compiler flags, provided by dpkg-buildflags(1)
-rw-r--r--debian/changelog1
-rwxr-xr-xdebian/rules7
2 files changed, 8 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 7da282d..e012584 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -3,6 +3,7 @@ ucspi-tcp (1:0.88-4) UNRELEASED; urgency=medium
* New maintainer (Closes: #907094)
* Convert patches to quilt
* Convert `debian/rules' to debhelper
+ * Respect compiler flags, provided by dpkg-buildflags(1)
-- Dmitry Bogatov <KAction@debian.org> Thu, 29 Nov 2018 06:22:03 +0000
diff --git a/debian/rules b/debian/rules
index 501dfd0..2d92d1e 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,5 +1,10 @@
#!/usr/bin/make -f
+export DEB_BUILD_MAINT_OPTIONS=hardening=+all
+include /usr/share/dpkg/default.mk
+export CFLAGS += $(shell getconf LFS_CFLAGS)
+export LDFLAGS += $(shell getconf LFS_LDFLAGS)
+
PREFIX_IPV4 = $(CURDIR)/debian/ucspi-tcp/usr
PREFIX_IPV6 = $(CURDIR)/debian/ucspi-tcp-ipv6/usr
@@ -12,6 +17,8 @@ override_dh_auto_configure:
xargs install -t ipv6 < FILES
cd ipv6 && patch -p1 < ../debian/ipv6-support.patch
echo $(PREFIX_IPV6) > ipv6/conf-home
+ echo '$(CC) $(CFLAGS) $(CPPFLAGS)' | tee ipv6/conf-cc conf-cc
+ echo '$(CC) $(LDFLAGS)' | tee ipv6/conf-ld conf-ld
override_dh_auto_build:
$(MAKE)