summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerrit Pape <pape@smarden.org>2008-06-17 21:31:34 +0000
committerDmitry Bogatov <KAction@debian.org>2018-11-29 05:18:33 +0000
commitd98777c7f350bf18c2673e312ae1f9adb4d16eec (patch)
tree6a230d203d299fb534c80c075a225ba81c2853a6
parent6ca8c808aaf0024970dc7ca620532acdb6f62487 (diff)
Import Debian changes 1:0.88-2
ucspi-tcp (1:0.88-2) unstable; urgency=low * debian/rules: install: force remove also auto_home.c before re-doing upstream targets install, instcheck (closes: #476070). * debian/diff/0003-Makefile-target-choose-do-not-depend-on-conf-home.diff: new: Makefile: target choose: do not depend on conf-home. * debian/control: Vcs-Git: http://smarden.org/git/ucspi-tcp.git/; Standards-Version: 3.8.0.1. * debian/rules: minor.
-rw-r--r--debian/changelog12
-rw-r--r--debian/control3
-rw-r--r--debian/diff/0001-error.h-include-errno.h-instead-of-extern-int.diff2
-rw-r--r--debian/diff/0002-rblsmtpd.c-don-t-use-a-the-default-rbl.maps.vix.com.diff2
-rw-r--r--debian/diff/0003-Makefile-target-choose-do-not-depend-on-conf-home.diff27
-rwxr-xr-xdebian/rules11
6 files changed, 48 insertions, 9 deletions
diff --git a/debian/changelog b/debian/changelog
index 473537e..9ff4269 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,15 @@
+ucspi-tcp (1:0.88-2) unstable; urgency=low
+
+ * debian/rules: install: force remove also auto_home.c before re-doing
+ upstream targets install, instcheck (closes: #476070).
+ * debian/diff/0003-Makefile-target-choose-do-not-depend-on-conf-home.diff:
+ new: Makefile: target choose: do not depend on conf-home.
+ * debian/control: Vcs-Git: http://smarden.org/git/ucspi-tcp.git/;
+ Standards-Version: 3.8.0.1.
+ * debian/rules: minor.
+
+ -- Gerrit Pape <pape@smarden.org> Tue, 17 Jun 2008 21:31:34 +0000
+
ucspi-tcp (1:0.88-1) unstable; urgency=low
* debian/changelog: add epoch 1 to supersede unofficial package.
diff --git a/debian/control b/debian/control
index 73734d7..069b760 100644
--- a/debian/control
+++ b/debian/control
@@ -2,7 +2,8 @@ Source: ucspi-tcp
Section: net
Priority: optional
Maintainer: Gerrit Pape <pape@smarden.org>
-Standards-Version: 3.7.2.2
+Standards-Version: 3.8.0.1
+Vcs-Git: http://smarden.org/git/ucspi-tcp.git/
Package: ucspi-tcp
Architecture: any
diff --git a/debian/diff/0001-error.h-include-errno.h-instead-of-extern-int.diff b/debian/diff/0001-error.h-include-errno.h-instead-of-extern-int.diff
index f154e66..433e575 100644
--- a/debian/diff/0001-error.h-include-errno.h-instead-of-extern-int.diff
+++ b/debian/diff/0001-error.h-include-errno.h-instead-of-extern-int.diff
@@ -21,5 +21,5 @@ index d5f3c7e..f660d93 100644
extern int error_intr;
extern int error_nomem;
--
-1.5.3.4
+1.5.5
diff --git a/debian/diff/0002-rblsmtpd.c-don-t-use-a-the-default-rbl.maps.vix.com.diff b/debian/diff/0002-rblsmtpd.c-don-t-use-a-the-default-rbl.maps.vix.com.diff
index dbeb307..a4d9603 100644
--- a/debian/diff/0002-rblsmtpd.c-don-t-use-a-the-default-rbl.maps.vix.com.diff
+++ b/debian/diff/0002-rblsmtpd.c-don-t-use-a-the-default-rbl.maps.vix.com.diff
@@ -39,5 +39,5 @@ index cc8ba2e..9695d9e 100644
pathexec_run(*argv,argv,envp);
--
-1.5.3.8
+1.5.5
diff --git a/debian/diff/0003-Makefile-target-choose-do-not-depend-on-conf-home.diff b/debian/diff/0003-Makefile-target-choose-do-not-depend-on-conf-home.diff
new file mode 100644
index 0000000..4f9bfbf
--- /dev/null
+++ b/debian/diff/0003-Makefile-target-choose-do-not-depend-on-conf-home.diff
@@ -0,0 +1,27 @@
+From 7512cc5f00d9ebfdd5a8512d61bc969a3cd20956 Mon Sep 17 00:00:00 2001
+From: Gerrit Pape <pape@smarden.org>
+Date: Wed, 16 Apr 2008 20:56:00 +0000
+Subject: [PATCH] Makefile: target choose: do not depend on conf-home
+
+---
+ Makefile | 3 +--
+ 1 files changed, 1 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index a67b0cb..bcf5bd5 100644
+--- a/Makefile
++++ b/Makefile
+@@ -145,9 +145,8 @@ compile chkshsgr.c exit.h
+ ./compile chkshsgr.c
+
+ choose: \
+-warn-auto.sh choose.sh conf-home
++warn-auto.sh choose.sh
+ cat warn-auto.sh choose.sh \
+- | sed s}HOME}"`head -1 conf-home`"}g \
+ > choose
+ chmod 755 choose
+
+--
+1.5.5
+
diff --git a/debian/rules b/debian/rules
index 17716e9..fbd14ee 100755
--- a/debian/rules
+++ b/debian/rules
@@ -36,13 +36,14 @@ install: deb-checkdir deb-checkuid build-stamp
install -d -m0755 '$(DIR)'/usr/bin
test -r conf-home'{orig}' || cp conf-home conf-home'{orig}'
echo '$(DIR)'/usr >conf-home
- rm -f install instcheck install.o instcheck.o hier.o auto_home.o
+ rm -f install instcheck install.o instcheck.o hier.o auto_home.c \
+ auto_home.o
$(MAKE) install instcheck
mv -f conf-home'{orig}' conf-home
./install
./instcheck
# fix up permissions
- chmod 0755 '$(DIR)'/usr '$(DIR)'/usr/bin
+ chmod g-s '$(DIR)'/usr '$(DIR)'/usr/bin
# strip
for i in addcr argv0 delcr fixcrio mconnect-io rblsmtpd recordio \
tcpclient tcprules tcprulescheck tcpserver; do \
@@ -57,14 +58,12 @@ install: deb-checkdir deb-checkuid build-stamp
# changelog
test -r changelog || ln -s CHANGES changelog
-binary-indep:
-
+binary: binary-arch binary-indep
binary-arch: install ucspi-tcp.deb
dpkg-shlibdeps '$(DIR)'/usr/bin/*
dpkg-gencontrol -isp -pucspi-tcp -P'$(DIR)'
dpkg -b '$(DIR)' ..
-
-binary: binary-indep binary-arch
+binary-indep:
.PHONY: patch build clean install binary-indep binary-arch binary