summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorGerrit Pape <pape@smarden.org>2008-06-17 21:31:34 +0000
committerDmitry Bogatov <KAction@debian.org>2018-11-29 05:18:33 +0000
commitd98777c7f350bf18c2673e312ae1f9adb4d16eec (patch)
tree6a230d203d299fb534c80c075a225ba81c2853a6 /debian/rules
parent6ca8c808aaf0024970dc7ca620532acdb6f62487 (diff)
Import Debian changes 1:0.88-2
ucspi-tcp (1:0.88-2) unstable; urgency=low * debian/rules: install: force remove also auto_home.c before re-doing upstream targets install, instcheck (closes: #476070). * debian/diff/0003-Makefile-target-choose-do-not-depend-on-conf-home.diff: new: Makefile: target choose: do not depend on conf-home. * debian/control: Vcs-Git: http://smarden.org/git/ucspi-tcp.git/; Standards-Version: 3.8.0.1. * debian/rules: minor.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules11
1 files changed, 5 insertions, 6 deletions
diff --git a/debian/rules b/debian/rules
index 17716e9..fbd14ee 100755
--- a/debian/rules
+++ b/debian/rules
@@ -36,13 +36,14 @@ install: deb-checkdir deb-checkuid build-stamp
install -d -m0755 '$(DIR)'/usr/bin
test -r conf-home'{orig}' || cp conf-home conf-home'{orig}'
echo '$(DIR)'/usr >conf-home
- rm -f install instcheck install.o instcheck.o hier.o auto_home.o
+ rm -f install instcheck install.o instcheck.o hier.o auto_home.c \
+ auto_home.o
$(MAKE) install instcheck
mv -f conf-home'{orig}' conf-home
./install
./instcheck
# fix up permissions
- chmod 0755 '$(DIR)'/usr '$(DIR)'/usr/bin
+ chmod g-s '$(DIR)'/usr '$(DIR)'/usr/bin
# strip
for i in addcr argv0 delcr fixcrio mconnect-io rblsmtpd recordio \
tcpclient tcprules tcprulescheck tcpserver; do \
@@ -57,14 +58,12 @@ install: deb-checkdir deb-checkuid build-stamp
# changelog
test -r changelog || ln -s CHANGES changelog
-binary-indep:
-
+binary: binary-arch binary-indep
binary-arch: install ucspi-tcp.deb
dpkg-shlibdeps '$(DIR)'/usr/bin/*
dpkg-gencontrol -isp -pucspi-tcp -P'$(DIR)'
dpkg -b '$(DIR)' ..
-
-binary: binary-indep binary-arch
+binary-indep:
.PHONY: patch build clean install binary-indep binary-arch binary