summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index bcf5bd5..1fe44fb 100644
--- a/Makefile
+++ b/Makefile
@@ -38,7 +38,7 @@ compile auto-str.c buffer.h readwrite.h exit.h
auto_home.c: \
auto-str conf-home
- ./auto-str auto_home `head -1 conf-home` > auto_home.c
+ ./auto-str auto_home $(DESTDIR)/`head -1 conf-home` > auto_home.c
auto_home.o: \
compile auto_home.c
@@ -158,6 +158,7 @@ commands.h
compile: \
warn-auto.sh conf-cc
( cat warn-auto.sh; \
+ [ '$V' != '1' ] || echo echo "`head -1 conf-cc`" '-c $${1+"$$@"}'; \
echo exec "`head -1 conf-cc`" '-c $${1+"$$@"}' \
) > compile
chmod 755 compile
@@ -384,6 +385,8 @@ load: \
warn-auto.sh conf-ld
( cat warn-auto.sh; \
echo 'main="$$1"; shift'; \
+ [ '$V' != '1' ] || echo echo "`head -1 conf-ld`" \
+ '-o "$$main" "$$main".o $${1+"$$@"}'; \
echo exec "`head -1 conf-ld`" \
'-o "$$main" "$$main".o $${1+"$$@"}' \
) > load