summaryrefslogtreecommitdiff
path: root/debian/patches/Makefile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/Makefile.patch')
-rw-r--r--debian/patches/Makefile.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/debian/patches/Makefile.patch b/debian/patches/Makefile.patch
new file mode 100644
index 0000000..4ec0a75
--- /dev/null
+++ b/debian/patches/Makefile.patch
@@ -0,0 +1,15 @@
+--- udfclient-0.8.1/Makefile.in 2015-08-05 20:29:01.000000000 +0200
++++ udfclient-0.8.1/Makefile.in 2016-03-04 23:10:21.621660536 +0100
+@@ -56,9 +56,10 @@ CFLAGS+= -DNEEDS_ISPRINT $(CPPFLAGS)
+ all: @BUILD_APPS@
+
+ install: @BUILD_APPS@
++ mkdir -p $(DESTDIR)$(bindir)
+ for app in $(APPS) $(SCSI_APPS); do \
+- echo "$(INSTALL) $$app $(bindir)/$$app"; \
+- $(INSTALL) $$app $(bindir)/$$app; \
++ echo "$(INSTALL) $$app $(DESTDIR)$(bindir)/$$app"; \
++ $(INSTALL) $$app $(DESTDIR)$(bindir)/$$app; \
+ done
+
+ depend: