summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVadim Mikhailov <mvp@users.noreply.github.com>2019-09-20 16:13:02 -0700
committerVadim Mikhailov <mvp@users.noreply.github.com>2019-09-20 17:43:36 -0700
commit05647714b6f0340aacb137fcc12957091201ec5a (patch)
tree023f1ed862b5c5348ff46daf5150094ad76c676c
parent4818eddc0389e2bba34a8cbe3ca5c67a6ad4d5ab (diff)
Apply debian hardening suggestions for Linux
Follow hardening tips per https://wiki.debian.org/Hardening. We have already applied `-z relro` before, now add `-z now` as well.
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index f6d69d3..482af36 100644
--- a/Makefile
+++ b/Makefile
@@ -21,7 +21,7 @@ endif
CFLAGS += -DPROGRAM_VERSION=\"$(GIT_VERSION)\"
ifeq ($(UNAME_S),Linux)
- LDFLAGS += -Wl,-z,relro -lusb-1.0
+ LDFLAGS += -Wl,-zrelro,-znow -lusb-1.0
endif
ifeq ($(UNAME_S),Darwin)