summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorgustavo panizzo <gfa@zumbi.com.ar>2019-09-08 01:57:41 +0200
committergustavo panizzo <gfa@zumbi.com.ar>2019-09-08 01:57:41 +0200
commit8bb87554c4f34543b74ae3c6be9bbd8995a4be98 (patch)
treee5a295a5aa552164be3fdd6bcd23e2468d431698
parentace401ecdc17866f3aad4e80c42430419df24050 (diff)
Commit patch queue (exported by git-debrebase)
[git-debrebase make-patches: export and commit patches]
-rw-r--r--debian/patches/debian-ways32
-rw-r--r--debian/patches/series1
2 files changed, 33 insertions, 0 deletions
diff --git a/debian/patches/debian-ways b/debian/patches/debian-ways
new file mode 100644
index 0000000..30ee601
--- /dev/null
+++ b/debian/patches/debian-ways
@@ -0,0 +1,32 @@
+From: gustavo panizzo <gfa@zumbi.com.ar>
+Date: Tue, 31 Jul 2018 10:28:52 +0800
+Subject: debian-ways
+
+---
+ Makefile | 13 ++++++++-----
+ 1 file changed, 8 insertions(+), 5 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index f6d69d3..021d836 100644
+--- a/Makefile
++++ b/Makefile
+@@ -14,11 +14,14 @@ RM := rm -rf
+ CC ?= gcc
+ CFLAGS ?= -g -O0
+ CFLAGS += -Wall -Wextra -std=c99 -pedantic
+-GIT_VERSION := $(shell git describe --abbrev=8 --dirty --always --tags)
+-ifeq ($(GIT_VERSION),)
+- GIT_VERSION := $(shell cat VERSION)
+-endif
+-CFLAGS += -DPROGRAM_VERSION=\"$(GIT_VERSION)\"
++
++# # Gets the full version of the source package including debian version
++DEB_VERSION := $(shell dpkg-parsechangelog | egrep '^Version:' | cut -f 2 -d ' ')
++DEB_NOEPOCH_VERSION := $(shell echo $(DEB_VERSION) | cut -d: -f2-)
++# # Gets only the upstream version of the package
++DEB_UPSTREAM_VERSION := $(shell echo $(DEB_NOEPOCH_VERSION) | sed 's/-[^-]*$$//')
++
++CFLAGS += -DPROGRAM_VERSION=\"$(DEB_UPSTREAM_VERSION)\"
+
+ ifeq ($(UNAME_S),Linux)
+ LDFLAGS += -Wl,-z,relro -lusb-1.0
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..b2e9488
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1 @@
+debian-ways