summaryrefslogtreecommitdiff
path: root/debian/patches/debian-ways
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/debian-ways')
-rw-r--r--debian/patches/debian-ways26
1 files changed, 26 insertions, 0 deletions
diff --git a/debian/patches/debian-ways b/debian/patches/debian-ways
new file mode 100644
index 0000000..a21ad54
--- /dev/null
+++ b/debian/patches/debian-ways
@@ -0,0 +1,26 @@
+From: gustavo panizzo <gfa@zumbi.com.ar>
+Date: Tue, 31 Jul 2018 10:28:52 +0800
+X-Dgit-Generated: 2.0.0-2 682ca592dbb14cb380d782be642634fea5a0e978
+Subject: debian-ways
+
+
+---
+
+--- uhubctl-2.0.0.orig/Makefile
++++ uhubctl-2.0.0/Makefile
+@@ -15,7 +15,14 @@ CC ?= gcc
+ CFLAGS ?= -g -O0
+ CFLAGS += -Wall -Wextra -std=c99 -pedantic
+ GIT_VERSION := $(shell git describe --abbrev=4 --dirty --always --tags)
+-CFLAGS += -DPROGRAM_VERSION=\"$(GIT_VERSION)\"
++
++# Gets the full version of the source package including debian version
++DEB_VERSION := $(shell dpkg-parsechangelog | egrep '^Version:' | cut -f 2 -d ' ')
++DEB_NOEPOCH_VERSION := $(shell echo $(DEB_VERSION) | cut -d: -f2-)
++# # Gets only the upstream version of the package
++DEB_UPSTREAM_VERSION := $(shell echo $(DEB_NOEPOCH_VERSION) | sed 's/-[^-]*$$//')
++
++CFLAGS += -DPROGRAM_VERSION=\"$(DEB_UPSTREAM_VERSION)\"
+
+ ifeq ($(UNAME_S),Linux)
+ LDFLAGS += -Wl,-z,relro -lusb-1.0