summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Preud'homme <robotux@celest.fr>2017-10-30 23:51:32 +0000
committerThomas Preud'homme <robotux@celest.fr>2017-11-24 23:57:26 +0000
commit1270082cdd7f9212b1b5acc2f046969d5e01513c (patch)
treed0b2a80268481958b601202e0ed24e381bca7fd4
parent2e5cb89f8c03f9ea607412c921e96421845f7afe (diff)
Generate and clean Qt message files.
-rw-r--r--debian/changelog1
-rw-r--r--debian/control3
-rwxr-xr-xdebian/rules4
3 files changed, 7 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 99a15f8..e00354b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -7,6 +7,7 @@ ultracopier (1.2.3.6-1) UNRELEASED; urgency=low
* debian/rules:
+ Update list of informations.xml to patch.
+ Update qmake project file to build.
+ + Generate and clean Qt message files.
* debian/watch:
+ Fix URL to upstream tarballs (thanks Bart Martens).
diff --git a/debian/control b/debian/control
index a3e5f86..6e9d7a0 100644
--- a/debian/control
+++ b/debian/control
@@ -2,7 +2,8 @@ Source: ultracopier
Section: utils
Priority: extra
Maintainer: Thomas Preud'homme <robotux@debian.org>
-Build-Depends: debhelper (>= 9), qtbase5-dev, kdelibs5-dev, qt5-qmake
+Build-Depends: debhelper (>= 9), qtbase5-dev, kdelibs5-dev, qt5-qmake,
+ qttools5-dev-tools
Standards-Version: 3.9.4
Homepage: http://ultracopier.first-world.info/
Vcs-Git: git://git.debian.org/collab-maint/ultracopier.git
diff --git a/debian/rules b/debian/rules
index 1dc71f5..2ce7042 100755
--- a/debian/rules
+++ b/debian/rules
@@ -28,6 +28,9 @@ override_dh_auto_configure: debian/detect_arch
for pluginsxml in $(patsubst %,%/informations.xml,$(archplugins)) ; do \
sed -i -r "s|(<architecture>).*(</architecture>)|\1$$ucp_arch\2|" $$pluginsxml; \
done
+ lrelease ultracopier-all-in-one-direct.pro
+ lrelease plugins/CopyEngine/Ultracopier/CopyEngine.pro
+ lrelease plugins/Themes/Oxygen/interface.pro
dh_auto_configure --buildsystem=qmake -- \
QMAKE_CXXFLAGS_RELEASE="$(CXXFLAGS) $(CPPFLAGS)" \
QMAKE_CXXFLAGS_DEBUG="$(CXXFLAGS) $(CPPFLAGS)" ultracopier-all-in-one-direct.pro
@@ -35,6 +38,7 @@ override_dh_auto_configure: debian/detect_arch
clean:
rm -f build
dh clean --buildsystem=qmake
+ find -name \*.qm -delete
for pluginsxml in $(patsubst %,%/informations.xml,$(archplugins)) ; do \
sed -i -r 's|(<architecture>).*(</architecture>)|\1windows-x86\2|' $$pluginsxml; \
done