summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Preud'homme <robotux@celest.fr>2013-03-21 17:43:48 +0100
committerThomas Preud'homme <robotux@celest.fr>2013-03-21 18:45:58 +0100
commit36bdbcee50f59bb2fc85fcad3f5b571710d17bcb (patch)
tree147476155a9aa04384d78acc2c6b5c4fac014fa1
parentfe3ad5d22abc41e93f408e3552e611abe60c8f3b (diff)
Drop exec permissions on flag.png at build time
-rw-r--r--debian/changelog1
-rwxr-xr-xdebian/rules4
2 files changed, 5 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index e3d238e..33b6a53 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -8,6 +8,7 @@ ultracopier (0.3.1.0-1) unstable; urgency=low
+ Explicitly set ultracopier.pro as the main project file.
+ Stop creating player_pause.png resource for Teracopy theme since it is
now in upstream tarball.
+ + Drop executable permissions on flag.png images at build time.
* Drop hardening-no-fortify-functions lintian override since it is a false
positive (thanks Paul Tagliamonte).
diff --git a/debian/rules b/debian/rules
index 27cb663..2ac9856 100755
--- a/debian/rules
+++ b/debian/rules
@@ -3,7 +3,10 @@
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
+exelang:=de it el ja pl zh tr
+
override_dh_auto_configure:
+ find plugins/Languages -name flag.png -exec chmod a-x {} +
dh_auto_configure --buildsystem=qmake -- \
QMAKE_CXXFLAGS_RELEASE="$(CXXFLAGS) $(CPPFLAGS)" \
QMAKE_CXXFLAGS_DEBUG="$(CXXFLAGS) $(CPPFLAGS)" build.pro
@@ -11,6 +14,7 @@ override_dh_auto_configure:
clean:
rm -f build
dh clean --buildsystem=qmake
+ for dir in $(exelang); do chmod go+x plugins/Languages/$$dir/flag.png ; done
build:
dh build --buildsystem=qmake