summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorThomas Preud'homme <thomas.preudhomme@celest.fr>2011-06-16 16:16:51 +0200
committerThomas Preud'homme <robotux@celest.fr>2013-01-04 12:56:06 +0100
commit2b912458d383dc575b421918ea59dfb62451112d (patch)
treeaa5a7e2766812b347e86a9875710ed14b1f9c9cf /debian/rules
parent685470d531d8f418ff2dc0c230fa591f4de9a3a8 (diff)
Use dpkg-buildflags to set build flags in rules
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules4
1 files changed, 4 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 44da3af..95b3d7a 100755
--- a/debian/rules
+++ b/debian/rules
@@ -3,6 +3,10 @@
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
+export CPPFLAGS:=$(shell dpkg-buildflags --get CPPFLAGS)
+export CFLAGS:=$(shell dpkg-buildflags --get CFLAGS)
+export LDFLAGS:=$(shell dpkg-buildflags --get LDFLAGS)
+
clean:
rm -f build
dh clean --buildsystem=qmake