summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorThomas Preud'homme <thomas.preudhomme@celest.fr>2011-08-06 19:25:04 +0200
committerThomas Preud'homme <robotux@celest.fr>2013-01-04 12:56:06 +0100
commit3078033f7e3c9baebb7cd778531417423e68e8a0 (patch)
treeaa5a7e2766812b347e86a9875710ed14b1f9c9cf /debian
parente4b53c8225049fd5cc6dc60c45ca99df149adab1 (diff)
Revert "debian/rules: better error handling (policy §4.6)."
I misunderstood policy §4.6 This reverts commit 3c5dfa30bfd57baa1c77f1bbf7bad4b865a8cefd.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog3
-rwxr-xr-xdebian/rules9
2 files changed, 7 insertions, 5 deletions
diff --git a/debian/changelog b/debian/changelog
index 9f6f3dd..11179ca 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,11 +2,10 @@ ultracopier (0.2.0.16-2) unstable; urgency=low
* debian/rules:
+ Use dpkg-buildflags to set build flags (CPPFLAGS, CFLAGS and LDFLAGS).
- + Better error handling in debian/rules.
* debian/copyright:
+ Document global license and copyright.
- -- Thomas Preud'homme <robotux@celest.fr> Sat, 06 Aug 2011 17:54:18 +0200
+ -- Thomas Preud'homme <robotux@celest.fr> Thu, 16 Jun 2011 16:16:43 +0200
ultracopier (0.2.0.16-1) unstable; urgency=low
diff --git a/debian/rules b/debian/rules
index 6c8f0a9..95b3d7a 100755
--- a/debian/rules
+++ b/debian/rules
@@ -8,13 +8,16 @@ export CFLAGS:=$(shell dpkg-buildflags --get CFLAGS)
export LDFLAGS:=$(shell dpkg-buildflags --get LDFLAGS)
clean:
- rm -f build && dh clean --buildsystem=qmake
+ rm -f build
+ dh clean --buildsystem=qmake
build:
- dh build --buildsystem=qmake && touch build
+ dh build --buildsystem=qmake
+ touch build
override_dh_fixperms:
- dh_fixperms && chmod a-x debian/ultracopier/usr/share/ultracopier/lang/*
+ dh_fixperms
+ chmod a-x debian/ultracopier/usr/share/ultracopier/lang/*
%:
dh $@ --buildsystem=qmake