summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog3
-rwxr-xr-xdebian/rules9
2 files changed, 5 insertions, 7 deletions
diff --git a/debian/changelog b/debian/changelog
index 11179ca..9f6f3dd 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,10 +2,11 @@ ultracopier (0.2.0.16-2) unstable; urgency=low
* debian/rules:
+ Use dpkg-buildflags to set build flags (CPPFLAGS, CFLAGS and LDFLAGS).
+ + Better error handling in debian/rules.
* debian/copyright:
+ Document global license and copyright.
- -- Thomas Preud'homme <robotux@celest.fr> Thu, 16 Jun 2011 16:16:43 +0200
+ -- Thomas Preud'homme <robotux@celest.fr> Sat, 06 Aug 2011 17:54:18 +0200
ultracopier (0.2.0.16-1) unstable; urgency=low
diff --git a/debian/rules b/debian/rules
index 95b3d7a..6c8f0a9 100755
--- a/debian/rules
+++ b/debian/rules
@@ -8,16 +8,13 @@ export CFLAGS:=$(shell dpkg-buildflags --get CFLAGS)
export LDFLAGS:=$(shell dpkg-buildflags --get LDFLAGS)
clean:
- rm -f build
- dh clean --buildsystem=qmake
+ rm -f build && dh clean --buildsystem=qmake
build:
- dh build --buildsystem=qmake
- touch build
+ dh build --buildsystem=qmake && touch build
override_dh_fixperms:
- dh_fixperms
- chmod a-x debian/ultracopier/usr/share/ultracopier/lang/*
+ dh_fixperms && chmod a-x debian/ultracopier/usr/share/ultracopier/lang/*
%:
dh $@ --buildsystem=qmake