summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2017-01-23 14:31:23 +0000
committerIan Jackson <ijackson@chiark.greenend.org.uk>2017-01-23 14:31:23 +0000
commitf53cd40f20431be077e96cb70e6dae9692276356 (patch)
treecb9e98d489b234fa4073395de00312eea9f88d5a
parent6cab4f8fc3de7f4e4cd5ab5a1989017ea8e695fe (diff)
Patch from Peter Benie.
* Specify #define YY_NO_INPUT, which avoids an unused function warning. Patch from Peter Benie.
-rw-r--r--debian/changelog4
-rw-r--r--lexer.l2
-rw-r--r--lexer.l.m42
3 files changed, 7 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 2642ac5..a8b333a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -14,7 +14,9 @@ userv (1.1.2~~iwj1) unstable; urgency=low
Packaging etc.
* Honour XCFLAGS.
* Use `%option nounput' rather than #define YY_NO_UNPUT.
- Patch from Peter Benie, but modified.
+ Patch from Peter Benie.
+ * Specify #define YY_NO_INPUT, which avoids an unused function warning.
+ Patch from Peter Benie.
* Update some copyright notices.
Debian packaging:
diff --git a/lexer.l b/lexer.l
index 27f5181..3dc8590 100644
--- a/lexer.l
+++ b/lexer.l
@@ -135,6 +135,8 @@ static struct error_handling eh = { tokv_word_errorstostderr, 0,0,0,0,0 };
static int dequote(char *inplace);
static void countnewlines(void);
+#define YY_NO_INPUT
+
%}
%option noyywrap
diff --git a/lexer.l.m4 b/lexer.l.m4
index 1c3f8ef..7be0be0 100644
--- a/lexer.l.m4
+++ b/lexer.l.m4
@@ -134,6 +134,8 @@ static struct error_handling eh = { tokv_word_errorstostderr, 0,0,0,0,0 };
static int dequote(char *inplace);
static void countnewlines(void);
+#define YY_NO_INPUT
+
%}
%option noyywrap