summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog7
-rw-r--r--debian/network/if-post-down.d/vlan6
-rw-r--r--debian/network/if-pre-up.d/vlan6
3 files changed, 15 insertions, 4 deletions
diff --git a/debian/changelog b/debian/changelog
index c4382b3..f7437f0 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+vlan (1.9-3.2) unstable; urgency=medium
+
+ * Non-maintainer upload.
+ * Don't exit when we're called by bridge-utils.
+
+ -- Andrew Shadura <andrewsh@debian.org> Tue, 01 Apr 2014 09:42:56 +0200
+
vlan (1.9-3.1) unstable; urgency=medium
* Non-maintainer upload.
diff --git a/debian/network/if-post-down.d/vlan b/debian/network/if-post-down.d/vlan
index bade97f..73e3dd9 100644
--- a/debian/network/if-post-down.d/vlan
+++ b/debian/network/if-post-down.d/vlan
@@ -11,12 +11,14 @@ case "$IFACE" in
;;
eth*.0*|bond*.0*|wlan*.0*)
# Silently ignore interfaces which ifupdown handles on its own
- [ -z "$IF_VLAN_RAW_DEVICE" ] && exit 0
+ # If IF_BRIDGE_PORTS is set, probably we're called by bridge-utils
+ [ -z "$IF_VLAN_RAW_DEVICE" -a -z "$IF_BRIDGE_PORTS" ] && exit 0
IF_VLAN_RAW_DEVICE=`echo $IFACE|sed "s/\(eth[0-9][0-9]*\)\..*/\1/;s/\(bond[0-9][0-9]*\)\..*/\1/;s/\(wlan[0-9][0-9]*\)\..*/\1/"`
;;
eth*.*|bond*.*|wlan*.*)
# Silently ignore interfaces which ifupdown handles on its own
- [ -z "$IF_VLAN_RAW_DEVICE" ] && exit 0
+ # If IF_BRIDGE_PORTS is set, probably we're called by bridge-utils
+ [ -z "$IF_VLAN_RAW_DEVICE" -a -z "$IF_BRIDGE_PORTS" ] && exit 0
IF_VLAN_RAW_DEVICE=`echo $IFACE|sed "s/\(eth[0-9][0-9]*\)\..*/\1/;s/\(bond[0-9][0-9]*\)\..*/\1/;s/\(wlan[0-9][0-9]*\)\..*/\1/"`
;;
# Test for vlan raw device (#196890, #292648)
diff --git a/debian/network/if-pre-up.d/vlan b/debian/network/if-pre-up.d/vlan
index 391c2ec..1580fc2 100644
--- a/debian/network/if-pre-up.d/vlan
+++ b/debian/network/if-pre-up.d/vlan
@@ -17,14 +17,16 @@ case "$IFACE" in
;;
eth*.0*|bond*.0*|wlan*.0*)
# Silently ignore interfaces which ifupdown handles on its own
- [ -z "$IF_VLAN_RAW_DEVICE" ] && exit 0
+ # If IF_BRIDGE_PORTS is set, probably we're called by bridge-utils
+ [ -z "$IF_VLAN_RAW_DEVICE" -a -z "$IF_BRIDGE_PORTS" ] && exit 0
vconfig set_name_type DEV_PLUS_VID
VLANID=`echo $IFACE|sed "s/eth[0-9][0-9]*\.0*//g;s/bond[0-9][0-9]*\.0*//;s/wlan[0-9][0-9]*\.0*//"`
IF_VLAN_RAW_DEVICE=`echo $IFACE|sed "s/\(eth[0-9][0-9]*\)\..*/\1/;s/\(bond[0-9][0-9]*\)\..*/\1/;s/\(wlan[0-9][0-9]*\)\..*/\1/"`
;;
eth*.*|bond*.*|wlan*.*)
# Silently ignore interfaces which ifupdown handles on its own
- [ -z "$IF_VLAN_RAW_DEVICE" ] && exit 0
+ # If IF_BRIDGE_PORTS is set, probably we're called by bridge-utils
+ [ -z "$IF_VLAN_RAW_DEVICE" -a -z "$IF_BRIDGE_PORTS" ] && exit 0
vconfig set_name_type DEV_PLUS_VID_NO_PAD
VLANID=`echo $IFACE|sed "s/eth[0-9][0-9]*\.0*//g;s/bond[0-9][0-9]*\.0*//g;s/wlan[0-9][0-9]*\.0*//g"`
IF_VLAN_RAW_DEVICE=`echo $IFACE|sed "s/\(eth[0-9][0-9]*\)\..*/\1/;s/\(bond[0-9][0-9]*\)\..*/\1/;s/\(wlan[0-9][0-9]*\)\..*/\1/"`