summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Shadura <andrew.shadura@collabora.co.uk>2019-09-12 21:25:27 +0200
committerAndrej Shadura <andrew.shadura@collabora.co.uk>2019-09-12 21:25:38 +0200
commit286f3335ff4f2eace92045de6d3fe953e5b84a1d (patch)
treef42f8c16c9f7aa60a88ef36b1c38260d48214bd8
parentc3436c64bc6dac5824902b453fa7539fd63ab52b (diff)
parentb1a87773058f73869e6a396c41055af2f11843e3 (diff)
Revert the reversions
-rw-r--r--debian/changelog7
-rw-r--r--debian/control29
-rw-r--r--debian/python-waitress.postinst10
-rw-r--r--debian/python-waitress.prerm9
-rwxr-xr-xdebian/rules4
5 files changed, 15 insertions, 44 deletions
diff --git a/debian/changelog b/debian/changelog
index 4266f3a..ee083e1 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+waitress (1.3.1-4) unstable; urgency=medium
+
+ * Revert the documentation package rename.
+ * Revert the reversion of the Python 3 removal.
+
+ -- Andrej Shadura <andrewsh@debian.org> Thu, 12 Sep 2019 21:24:08 +0200
+
waitress (1.3.1-3) unstable; urgency=medium
* Revert the Python 3 removal.
diff --git a/debian/control b/debian/control
index badc577..28b8c98 100644
--- a/debian/control
+++ b/debian/control
@@ -1,43 +1,28 @@
Source: waitress
-Maintainer: Andrej Shadura <andrewsh@debian.org>
+Maintainer: Debian Python Modules Team <python-modules-team@lists.alioth.debian.org>
+Uploaders: Andrej Shadura <andrewsh@debian.org>
Section: python
Priority: optional
Homepage: https://github.com/Pylons/waitress
Build-Depends:
debhelper-compat (= 12),
dh-python,
- python-all (>= 2.7),
- python-setuptools (>= 0.6.24),
- python-sphinx (>= 1.0.7+dfsg) | python3-sphinx,
python3-all (>= 3.3),
- python3-setuptools (>= 0.6.24)
+ python3-setuptools (>= 0.6.24),
+ python3-sphinx
Standards-Version: 3.9.5
Vcs-Browser: https://salsa.debian.org/debian/waitress
Vcs-Git: https://salsa.debian.org/debian/waitress.git
Testsuite: autopkgtest-pkg-python
-Package: python-waitress
-Architecture: all
-Depends:
- ${misc:Depends},
- ${python:Depends}
-Provides:
- ${python:Provides}
-Suggests:
- python-waitress-doc
-Description: production-quality pure-Python WSGI server
- Waitress is meant to be a production-quality pure-Python WSGI server with
- very acceptable performance. It has no dependencies except ones which live
- in the Python standard library. It runs on CPython on Unix and Windows under
- Python 2.7+ and Python 3.3+. It is also known to run on PyPy 1.6.0 on UNIX.
- It supports HTTP/1.0 and HTTP/1.1.
-
Package: python-waitress-doc
Section: doc
Architecture: all
Depends:
${misc:Depends},
${sphinxdoc:Depends}
+Provides:
+ python3-waitress-doc
Description: production-quality pure-Python WSGI server (documentation)
Waitress is meant to be a production-quality pure-Python WSGI server with
very acceptable performance. It has no dependencies except ones which live
@@ -53,7 +38,7 @@ Depends:
${misc:Depends},
${python3:Depends}
Suggests:
- python-waitress-doc
+ python3-waitress-doc
Description: production-quality pure-Python WSGI server (Python 3)
Waitress is meant to be a production-quality pure-Python WSGI server with
very acceptable performance. It has no dependencies except ones which live
diff --git a/debian/python-waitress.postinst b/debian/python-waitress.postinst
deleted file mode 100644
index ba76437..0000000
--- a/debian/python-waitress.postinst
+++ /dev/null
@@ -1,10 +0,0 @@
-#!/bin/sh
-
-set -e
-
-if [ "$1" = "configure" ]
-then
- update-alternatives --remove waitress-serve /usr/bin/waitress-serve-python2 || true
-fi
-
-#DEBHELPER#
diff --git a/debian/python-waitress.prerm b/debian/python-waitress.prerm
deleted file mode 100644
index 87b6f15..0000000
--- a/debian/python-waitress.prerm
+++ /dev/null
@@ -1,9 +0,0 @@
-#!/bin/sh
-
-set -e
-
-if [ "$1" != "upgrade" ] ; then
- update-alternatives --remove waitress-serve /usr/bin/waitress-serve-python2 || true
-fi
-
-#DEBHELPER#
diff --git a/debian/rules b/debian/rules
index c0433d9..aa609cb 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,6 +1,5 @@
#!/usr/bin/make -f
-export PYBUILD_DESTDIR_python2=debian/python-waitress/
export PYBUILD_DESTDIR_python3=debian/python3-waitress/
export PYBUILD_DISABLE=test
@@ -9,7 +8,7 @@ BUILD_DATE = $(shell LC_ALL=C date -u "+%B %d, %Y" -d "$(LAST_CHANGE)")
SPHINXOPTS := -N -D html_last_updated_fmt=\"$(BUILD_DATE)\"
%:
- dh $@ --with python2,python3,sphinxdoc --buildsystem=pybuild
+ dh $@ --with python3,sphinxdoc --buildsystem=pybuild
override_dh_auto_build:
dh_auto_build -v
@@ -21,7 +20,6 @@ override_dh_auto_clean:
override_dh_auto_install:
dh_auto_install
- mv debian/python-waitress/usr/bin/waitress-serve debian/python-waitress/usr/bin/waitress-serve-python2
mv debian/python3-waitress/usr/bin/waitress-serve debian/python3-waitress/usr/bin/waitress-serve-python3
sed -i '1s,.*,#!/usr/bin/python3,' debian/python3-waitress/usr/bin/waitress-serve-python3