summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Shadura <andrewsh@debian.org>2017-09-03 18:08:02 +0200
committerAndrew Shadura <andrewsh@debian.org>2017-09-03 18:59:01 +0200
commit4d626cfa7c25dc1b092c146eb1f779e7c95a51c9 (patch)
tree73cd2aff30bcb702e174813ae6b81bb09eac4dd5
parent30040032a404b468277b5eb0aba0f6b4ecc281f8 (diff)
Refresh patches.
-rw-r--r--debian/patches/01-parallel_mdoc.patch15
-rw-r--r--debian/patches/02-pkgconfig_library_path.patch25
-rw-r--r--debian/patches/03_dllmap.patch18
3 files changed, 28 insertions, 30 deletions
diff --git a/debian/patches/01-parallel_mdoc.patch b/debian/patches/01-parallel_mdoc.patch
index 63d8288..c1b5faf 100644
--- a/debian/patches/01-parallel_mdoc.patch
+++ b/debian/patches/01-parallel_mdoc.patch
@@ -1,19 +1,20 @@
-Author: Andrew Shadura <andrewsh@debian.org>
-Description: Don't run things twice.
+From: Andrew Shadura <andrewsh@debian.org>
+Subject: Don't run things twice.
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
-@@ -15,9 +15,6 @@
- update:
- $(MDOC) update $(SOUPSHARP_LIBS) --out=en $(ASSEMBLIES)
+@@ -18,10 +18,6 @@
+ mkdir -p $(srcdir)/en
+ $(MONODOCER) $(UPDATE_ASSEMBLIES) -path:en
-$(srcdir)/en/*/*.xml $(srcdir)/en/*.xml:
-- $(MDOC) update $(SOUPSHARP_LIBS) --out=en $(ASSEMBLIES)
+- mkdir -p $(srcdir)/en
+- $(MONODOCER) $(UPDATE_ASSEMBLIES) -path:en
-
$(ASSEMBLY_NAME)-docs.source:
@echo "Generating $@"
@echo "<?xml version=\"1.0\"?>" > $@
-@@ -25,7 +22,9 @@
+@@ -29,7 +25,9 @@
@echo " <source provider=\"ecma\" basefile=\"$(ASSEMBLY_NAME)-docs\" path=\"classlib-$(ASSEMBLY_SHORTNAME)\"/>" >> $@
@echo "</monodoc>" >> $@
diff --git a/debian/patches/02-pkgconfig_library_path.patch b/debian/patches/02-pkgconfig_library_path.patch
index 5ed39b9..071753c 100644
--- a/debian/patches/02-pkgconfig_library_path.patch
+++ b/debian/patches/02-pkgconfig_library_path.patch
@@ -1,15 +1,12 @@
-Description: A few fixes in pkgconfig file
-Author: Thanh Tung Nguyen <thngtong@gmail.com>
-Last-Update: 2015-01-18
+From: Thanh Tung Nguyen <thngtong@gmail.com>
+Subject: A few fixes in pkgconfig file
+Last-Update: 2017-09-03
---- a/webkitgtk-sharp-3.0.pc.in
-+++ b/webkitgtk-sharp-3.0.pc.in
-@@ -1,7 +1,7 @@
- prefix=@prefix@
- exec_prefix=${prefix}
- libdir=@libdir@
--pkglibdir=${exec_prefix}/lib/mono/@ASSEMBLY_NAME@
-+pkglibdir=${exec_prefix}/lib/cli/@ASSEMBLY_PC@
- gapidir=@GAPIXMLDIR@
-
- Name: @ASSEMBLY_TITLE@
+--- a/webkit2-sharp-4.0.pc.in
++++ b/webkit2-sharp-4.0.pc.in
+@@ -6,4 +6,4 @@
+ Description: @ASSEMBLY_DESCRIPTION@
+ Version: @VERSION@
+ Requires:
+-Libs: -r:${libdir}/mono/@ASSEMBLY_NAME@/@ASSEMBLY_NAME@.dll
++Libs: -r:${libdir}/cli/@ASSEMBLY_PC@/@ASSEMBLY_NAME@.dll
diff --git a/debian/patches/03_dllmap.patch b/debian/patches/03_dllmap.patch
index 8100edf..b00f936 100644
--- a/debian/patches/03_dllmap.patch
+++ b/debian/patches/03_dllmap.patch
@@ -1,11 +1,11 @@
-Description: Tell the loader where to look for the glue library. Ugh, this is so ugly.
-Author: Andrew Shadura <andrewsh@debian.org>
+From: Andrew Shadura <andrewsh@debian.org>
+Subject: Tell the loader where to look for the glue library. Ugh, this is so ugly.
---- a/out/webkitgtk-sharp.dll.config
-+++ b/out/webkitgtk-sharp.dll.config
-@@ -2,4 +2,5 @@
- <dllmap dll="webkitgtk-3.0" target="libwebkitgtk-3.0.so.0"/>
- <dllmap dll="libsoup-2.4" target="libsoup-2.4.so.1"/>
- <dllmap dll="libgtk-3-0.dll" target="libgtk-3.so.0"/>
-+ <dllmap dll="libwebkitgtksharpglue-1.10.2.so" target="/usr/lib/cli/webkitgtk-sharp-3.0/libwebkitgtksharpglue-1.10.2.so"/>
+--- a/sources/webkit2-sharp.dll.config
++++ b/sources/webkit2-sharp.dll.config
+@@ -2,2 +2,5 @@
+ <dllmap dll="webkit2gtk-4.0" target="libwebkit2gtk-4.0.so.37"/>
++ <dllmap dll="libsoup-2.4" target="libsoup-2.4.so.1"/>
++ <dllmap dll="libgtk-3-0.dll" target="libgtk-3.so.0"/>
++ <dllmap dll="libwebkit2sharpglue-2.10.9.so" target="/usr/lib/cli/webkit2-sharp-4.0/libwebkit2sharpglue-2.10.9.so"/>
</configuration>