summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Shadura <andrewsh@debian.org>2016-01-18 19:23:32 +0100
committerAndrew Shadura <andrewsh@debian.org>2016-01-18 19:23:32 +0100
commitbc448818d46da3a8fa49e0f626aff3723185ad6f (patch)
tree1925889e9d959e9f0f1c11e07e6be14837796ff2
parent20acffd790841d08d1d62c3577a98df117a311fd (diff)
Unbreak parallel build.
-rw-r--r--debian/patches/01-parallel_mdoc.patch26
-rw-r--r--debian/patches/series1
-rw-r--r--doc/Makefile.am7
3 files changed, 30 insertions, 4 deletions
diff --git a/debian/patches/01-parallel_mdoc.patch b/debian/patches/01-parallel_mdoc.patch
new file mode 100644
index 0000000..63d8288
--- /dev/null
+++ b/debian/patches/01-parallel_mdoc.patch
@@ -0,0 +1,26 @@
+Author: Andrew Shadura <andrewsh@debian.org>
+Description: Don't run things twice.
+
+--- a/doc/Makefile.am
++++ b/doc/Makefile.am
+@@ -15,9 +15,6 @@
+ update:
+ $(MDOC) update $(SOUPSHARP_LIBS) --out=en $(ASSEMBLIES)
+
+-$(srcdir)/en/*/*.xml $(srcdir)/en/*.xml:
+- $(MDOC) update $(SOUPSHARP_LIBS) --out=en $(ASSEMBLIES)
+-
+ $(ASSEMBLY_NAME)-docs.source:
+ @echo "Generating $@"
+ @echo "<?xml version=\"1.0\"?>" > $@
+@@ -25,7 +22,9 @@
+ @echo " <source provider=\"ecma\" basefile=\"$(ASSEMBLY_NAME)-docs\" path=\"classlib-$(ASSEMBLY_SHORTNAME)\"/>" >> $@
+ @echo "</monodoc>" >> $@
+
+-$(ASSEMBLY_NAME)-docs.zip $(ASSEMBLY_NAME)-docs.tree: $(srcdir)/en/*/*.xml $(srcdir)/en/*.xml
++$(ASSEMBLY_NAME)-docs.zip $(ASSEMBLY_NAME)-docs.tree: assemble
++
++assemble: update
+ $(MDASSEMBLER) --ecma $(srcdir)/en -o $(ASSEMBLY_NAME)-docs
+
+ CLEANFILES = $(TARGETS)
diff --git a/debian/patches/series b/debian/patches/series
index 24400a0..d7f8b59 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,2 +1,3 @@
+01-parallel_mdoc.patch
02-pkgconfig_library_path.patch
03_dllmap.patch
diff --git a/doc/Makefile.am b/doc/Makefile.am
index a9730d3..c553801 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -15,9 +15,6 @@ all: $(TARGETS)
update:
$(MDOC) update $(SOUPSHARP_LIBS) --out=en $(ASSEMBLIES)
-$(srcdir)/en/*/*.xml $(srcdir)/en/*.xml:
- $(MDOC) update $(SOUPSHARP_LIBS) --out=en $(ASSEMBLIES)
-
$(ASSEMBLY_NAME)-docs.source:
@echo "Generating $@"
@echo "<?xml version=\"1.0\"?>" > $@
@@ -25,7 +22,9 @@ $(ASSEMBLY_NAME)-docs.source:
@echo " <source provider=\"ecma\" basefile=\"$(ASSEMBLY_NAME)-docs\" path=\"classlib-$(ASSEMBLY_SHORTNAME)\"/>" >> $@
@echo "</monodoc>" >> $@
-$(ASSEMBLY_NAME)-docs.zip $(ASSEMBLY_NAME)-docs.tree: $(srcdir)/en/*/*.xml $(srcdir)/en/*.xml
+$(ASSEMBLY_NAME)-docs.zip $(ASSEMBLY_NAME)-docs.tree: assemble
+
+assemble: update
$(MDASSEMBLER) --ecma $(srcdir)/en -o $(ASSEMBLY_NAME)-docs
CLEANFILES = $(TARGETS)