summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorDidier Raboud <odyx@debian.org>2011-07-01 16:42:45 +0200
committerDidier Raboud <odyx@debian.org>2011-08-03 11:27:46 +0200
commit62818d09aa50c5b8aebdca2913172068f50bb7a7 (patch)
treed18fde2a8d0a3b605412e47c9334ad3c95691ec9 /Makefile
parent552bd5404b864c131433fba8e6ee81b14abf6fef (diff)
Rename the NO_KFREEBSD make envvar to NOT_ALLKERNELS to open the doors to GNU/Hurd too.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index 381e567..3229b75 100644
--- a/Makefile
+++ b/Makefile
@@ -54,10 +54,10 @@ OPTIONS_TXT += +pxe
endif
# Disabling the kFreeBSD download
-ifndef NO_KFREEBSD
-MAKENSIS += -DKFREEBSD=yes
+ifndef NOT_ALLKERNELS
+MAKENSIS += -DALLKERNELS=yes
else
-OPTIONS_TXT += -kbsd
+OPTIONS_TXT += =linux
endif
ifdef OPTIONS_TXT
@@ -76,7 +76,8 @@ GRUB_MODULES += search linux bsd multiboot vbe boot
GRUB_MODULES += minicmd cat cpuid chain halt help ls reboot
# useful for loading files from ISO images
GRUB_MODULES += loopback iso9660
-ifndef NO_KFREEBSD
+ifndef NOT_ALLKERNELS
+# gzio is needed for kFreeBSD
GRUB_MODULES += gzio
endif
ifdef PXE