summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorRobert Millan <rmh@debian.org>2009-03-24 19:44:06 +0000
committerRobert Millan <rmh@debian.org>2009-03-24 19:44:06 +0000
commit66e228e3fc64ec7ce2236b455930868c7e9ea1e4 (patch)
treea87997a930678aa72d2237d1d285bebecd2b02f4 /Makefile
parentf0d6cc4c7a42912ef13a285d23f2157894fe744b (diff)
Update to new NSIS plugin API. (Closes: #517174)
r57971
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 4ea7aeb..e23e9e1 100644
--- a/Makefile
+++ b/Makefile
@@ -6,7 +6,7 @@ VERSION := $(shell head -n 1 debian/changelog | sed -e "s/^$(PACKAGE) (\(.*\)).*
NSIS_CC := i586-mingw32msvc-gcc -Os
NSIS_STRIP := i586-mingw32msvc-strip
-NSIS_CFLAGS := -Wl,--file-alignment,512 -Werror -D_WIN32_WINNT=0x0500
+NSIS_CFLAGS := -Wl,--file-alignment,512 -Werror -D_WIN32_WINNT=0x0500 -L/usr/i586-mingw32msvc/lib/nsis -lpluginapi
MAKENSIS := makensis
ifdef NETWORK_BASE_URL
@@ -52,7 +52,7 @@ license: license.in debian/changelog
sed -e "s/@VERSION@/$(VERSION)/g" < $< > $@
plugins/win32-loader.dll: plugins/cpuid/cpuid.c plugins/cpuid/plugin.c plugins/systeminfo/systeminfo.c plugins/string.c
- $(NSIS_CC) $(NSIS_CFLAGS) $^ -shared -o $@
+ $(NSIS_CC) $^ $(NSIS_CFLAGS) -shared -o $@
$(NSIS_STRIP) $@
iso: stable.iso daily.iso