summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorDidier Raboud <odyx@debian.org>2011-02-16 13:29:41 +0100
committerDidier Raboud <odyx@debian.org>2011-02-16 13:39:27 +0100
commit848ba05ce20c3495d23d7402d07e90b02febcc2d (patch)
tree37f333c4c18fce872b216db1ddcdf10e98ccd2ba /Makefile
parente2247e9913a894c3ec6acd1222d779a6dfc0afa6 (diff)
Remove license click-trough.
It's not an obligation from NSIS nor the GPL and is considered 'bad-taste' with regards to DFSG.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile7
1 files changed, 2 insertions, 5 deletions
diff --git a/Makefile b/Makefile
index 33e36dd..a93d928 100644
--- a/Makefile
+++ b/Makefile
@@ -100,7 +100,7 @@ win32-loader.exe: main.nsi maps.ini \
templates/binary_choice.ini templates/graphics.ini templates/custom.ini templates/4_choices.ini \
plugins/cpuid/test64.dll plugins/systeminfo/systeminfo.dll plugins/string.dll \
pxe.target \
- swirl.ico license loadlin.pif loadlin.exe g2ldr g2ldr.mbr
+ swirl.ico loadlin.pif loadlin.exe g2ldr g2ldr.mbr
$(MAKE) -C l10n
$(MAKENSIS) main.nsi
ifndef OUTFILE_NAME
@@ -109,9 +109,6 @@ else
du -h $(OUTFILE_NAME)
endif
-license: license.in debian/changelog
- sed -e "s/@VERSION@/$(VERSION)/g" < $< > $@
-
plugins/cpuid/test64.dll: plugins/cpuid/cpuid.c plugins/cpuid/plugin.c
$(NSIS_CC) $^ $(NSIS_CFLAGS) -shared -o $@
$(NSIS_STRIP) $@
@@ -190,7 +187,7 @@ netboot/stable/% netboot/daily/%: %
clean:
$(MAKE) -C l10n clean
rm -f plugins/cpuid/*.dll plugins/cpuid/*.exe plugins/systeminfo/*.dll plugins/*.dll win32-loader.exe \
- *.iso *~ */*~ license core.img g2ldr g2ldr.mbr loadlin.pif loadlin.exe
+ *.iso *~ */*~ core.img g2ldr g2ldr.mbr loadlin.pif loadlin.exe
distclean: clean
rm -rf netboot