summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorDidier Raboud <odyx@debian.org>2011-02-13 19:15:31 +0100
committerDidier Raboud <odyx@debian.org>2011-02-13 19:15:31 +0100
commit9685b4d87455bb86702fe97dd6f16307a0665ad2 (patch)
tree9930be9e706f1548512bcca75b0914e80ee39ebf /Makefile
parent935e93e417fc33837778e2ba041e2255c3e5973d (diff)
Allow build-time outfile name selection
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index c051620..33e36dd 100644
--- a/Makefile
+++ b/Makefile
@@ -20,6 +20,10 @@ MAKENSIS := makensis -V3
# Add to it some version'ing and date
MAKENSIS += -DVERSION=$(VERSION) -D4DIGITS_DATE=`date +%Y.%m.%d.%H%M`
+ifdef OUTFILE_NAME
+MAKENSIS += -D_OUTFILE_NAME=$(OUTFILE_NAME)
+endif
+
# Distribution name (ASCII only, please)
ifdef TARGET_DISTRO
MAKENSIS += -DTARGET_DISTRO=$(TARGET_DISTRO)
@@ -99,7 +103,11 @@ win32-loader.exe: main.nsi maps.ini \
swirl.ico license loadlin.pif loadlin.exe g2ldr g2ldr.mbr
$(MAKE) -C l10n
$(MAKENSIS) main.nsi
+ifndef OUTFILE_NAME
du -h win32-loader.exe
+else
+ du -h $(OUTFILE_NAME)
+endif
license: license.in debian/changelog
sed -e "s/@VERSION@/$(VERSION)/g" < $< > $@