summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorDidier Raboud <odyx@debian.org>2011-02-02 19:20:31 +0100
committerDidier Raboud <odyx@debian.org>2011-02-02 19:41:58 +0100
commitb0102be0e86e9dda5e0f222fed22cbec9bc49189 (patch)
tree1d837138482dddc07fc713a2e49df2eb9d3ec0e3 /Makefile
parent7b6cd8679f4c3e3be720693ab3d6d8f0d08034de (diff)
Make the Windows bootloader entry distro- and kernel- specific.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index c71823b..5c0a8ec 100644
--- a/Makefile
+++ b/Makefile
@@ -15,6 +15,12 @@ NSIS_CFLAGS += -L/usr/i586-mingw32msvc/lib/nsis -lpluginapi
endif
MAKENSIS := makensis -V3
+
+# Distribution name (ASCII only, please)
+ifdef DISTRO_NAME
+MAKENSIS += -DDISTRO_NAME=$(DISTRO_NAME)
+endif
+
# Standalone version : Not linked to a website with preseed.cfg
ifdef STANDALONE
MAKENSIS += -DNOCD=yes