summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorDidier Raboud <odyx@debian.org>2011-02-21 00:56:16 +0100
committerDidier Raboud <odyx@debian.org>2011-02-21 14:53:30 +0100
commitf4dedffe4ee62c2d37b8dc8bae13ee1009704d73 (patch)
treea569cad3c3d89b0df0b479a7b2f43d60bc16c0cb /Makefile
parent7c9a388b4c9a19c537ea39c725d44fb01d7f5f6a (diff)
Initual sha1sum NSIS plugin implementation.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 5715fc2..8dc66d8 100644
--- a/Makefile
+++ b/Makefile
@@ -104,6 +104,7 @@ endif
win32-loader.exe: main.nsi maps.ini \
templates/binary_choice.ini templates/graphics.ini templates/custom.ini templates/4_choices.ini \
plugins/cpuid/test64.dll plugins/systeminfo/systeminfo.dll plugins/string.dll \
+ plugins/sha1sum.dll \
pxe.target \
swirl.ico loadlin.pif loadlin.exe g2ldr g2ldr.mbr
$(MAKE) -C l10n
@@ -126,6 +127,10 @@ plugins/string.dll: plugins/string.c
$(NSIS_CC) $^ $(NSIS_CFLAGS) -shared -o $@
$(NSIS_STRIP) $@
+plugins/sha1sum.dll: plugins/sha1sum.c
+ $(NSIS_CC) $^ $(NSIS_CFLAGS) -shared -o $@
+ $(NSIS_STRIP) $@
+
iso: stable.iso daily.iso
stable.iso: \
netboot/download-stable-stamp \