summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorJérémy Bobbio <lunar@debian.org>2015-04-29 09:14:12 +0200
committerDidier Raboud <odyx@debian.org>2015-04-29 09:14:12 +0200
commitfeaaed39d4fb7ef95a14ffc933912a89f32aeefc (patch)
tree61386ce35b7f6656c8aa36ddf8602cdf690b17c3 /Makefile
parent559c2c9c005f56942d8581c6827b7be4fe036b0a (diff)
Makefile syntax fix in PXE targets definition
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index e5ba0de..6145367 100644
--- a/Makefile
+++ b/Makefile
@@ -113,9 +113,9 @@ pxe.lkrn: /usr/lib/ipxe/ipxe.lkrn
cp $^ $@
ifdef PXE
-pxe.target: pxe.lkrn templates/ternary_choice.ini
+PXE_TARGETS = pxe.lkrn templates/ternary_choice.ini
else
-pxe.target:
+PXE_TARGETS =
endif
templates/gtk.bmp: templates/gtk_orig.png
@@ -134,7 +134,7 @@ win32-loader.exe: main.nsi maps.ini \
templates/gtk.bmp templates/text.bmp \
plugins/cpuid/test64.dll plugins/systeminfo/systeminfo.dll plugins/string.dll \
plugins/sha1sum.dll \
- pxe.target \
+ $(PXE_TARGETS) \
win32-loader.ico loadlin.pif loadlin.exe g2ldr g2ldr.mbr
find $^ -newermt "$(BUILD_DATE)" -print0 | xargs -0r touch --date="$(BUILD_DATE)"
$(MAKE) -C l10n