summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorDidier Raboud <odyx@debian.org>2017-09-04 11:44:21 +0200
committerDidier Raboud <odyx@debian.org>2017-09-04 11:44:21 +0200
commit20adce948a0797bd0f07d8c95784efa13ee28bae (patch)
tree36820fee143d0ce444d14fd2ce3ca6ff0b77f378 /debian
parent8ba506f0ce9d4ba095096d57d1272075c1651421 (diff)
parent0d96e472feb28199d5021ca9b6954eb531cbf88c (diff)
Merge branch 'master' into nsis3
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog40
-rw-r--r--debian/control4
-rwxr-xr-xdebian/rules22
-rw-r--r--debian/source/options2
4 files changed, 50 insertions, 18 deletions
diff --git a/debian/changelog b/debian/changelog
index a0d14f5..695c237 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,43 @@
+win32-loader (0.8.4) unstable; urgency=medium
+
+ * The « Folivora » release
+
+ * Drop bz2 compression for source
+ * Replace all mirror urls with deb.debian.org
+
+ -- Didier Raboud <odyx@debian.org> Sun, 18 Jun 2017 10:01:32 +0200
+
+win32-loader (0.8.3) unstable; urgency=low
+
+ * The « Pippita » release
+
+ * Fix FTBFS on i386: use gawk to prepare README file (Closes: #860695)
+
+ -- Didier Raboud <odyx@debian.org> Wed, 19 Apr 2017 18:03:11 +0200
+
+win32-loader (0.8.2) unstable; urgency=medium
+
+ * The « Iao » release
+
+ * Fix dpkg-query calls to use source:* for Version and Package directly
+ - Add Build-Dependency on dpkg (>= 1.16.2) for that support
+ - Fixes the FTBFS revealed by loadlin's binNMU
+ (Closes: #858104)
+
+ -- Didier Raboud <odyx@debian.org> Mon, 20 Mar 2017 21:23:59 +0100
+
+win32-loader (0.8.1) unstable; urgency=medium
+
+ * The « poipoi » release
+
+ * As NSIS doesn't support downloading from https (#819092), and as
+ d-i dailies are now on an https-enforced hosts: don't allow branch
+ or kernel selection
+ * Replace the Lines screenshot by a recent softWaves screenshot
+ * Refresh debian/copyright in CF1.0
+
+ -- Didier Raboud <odyx@debian.org> Thu, 29 Dec 2016 20:57:22 +0100
+
win32-loader (0.8.0) unstable; urgency=low
* The « Κρυπτεία σκυτάλη » release
diff --git a/debian/control b/debian/control
index aded66f..ae54495 100644
--- a/debian/control
+++ b/debian/control
@@ -2,13 +2,15 @@ Source: win32-loader
Section: utils
Priority: extra
Maintainer: Debian Install System Team <debian-boot@lists.debian.org>
-Uploaders: Robert Millan <rmh.debian@aybabtu.com>, Didier Raboud <odyx@debian.org>, Christian Perrier <bubulle@debian.org>
+Uploaders: Didier Raboud <odyx@debian.org>
Build-Depends:
+ dpkg (>= 1.16.2),
debhelper (>= 9),
nsis (>= 3), nsis-pluginapi,
mingw-w64,
libgcrypt-mingw-w64-dev, libgpg-error-mingw-w64-dev,
librsvg2-bin, icoutils,
+ gawk,
gettext,
grub-pc-bin (>= 1.99~rc1-3),
imagemagick,
diff --git a/debian/rules b/debian/rules
index 266c178..249299b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -13,23 +13,13 @@ B_D_PACKAGES := grub-pc-bin cpio-win32 gzip-win32 gpgv-win32 debian-archive-keyr
PACKAGES_LIST := $(shell set -e; \
for p in ${B_D_PACKAGES}; \
do \
- if test `dpkg-query --showformat='x$${Source}x' --show $$p` = "xx"; \
- then \
- dpkg-query --showformat='$${Package;-25} $${Version;-25} http://ftp.debian.org/debian/pool/main/$${Package;1}/$${Package}\\n' --show $$p; \
- else \
- dpkg-query --showformat='$${Package;-25} $${Version;-25} http://ftp.debian.org/debian/pool/main/$${Source;1}/$${Source}\\n' --show $$p; \
- fi; \
+ dpkg-query --showformat='$${source:Package;-25} $${source:Version;-25} http://deb.debian.org/debian/pool/main/$${source:Package;1}/$${source:Package}\\n' --show $$p; \
done)
BUILT_USING_LIST := $(shell set -e; \
for p in ${B_D_PACKAGES}; \
do \
- if test `dpkg-query --showformat='x$${Source}x' --show $$p` = "xx"; \
- then \
- dpkg-query --showformat='$${Package} (= $${Version}), ' --show $$p; \
- else \
- dpkg-query --showformat='$${Source} (= $${Version}), ' --show $$p; \
- fi; \
+ dpkg-query --showformat='$${source:Package} (= $${source:Version}), ' --show $$p; \
done)
NSIS_VERSION := $(shell dpkg-query -f='$${Version}' -W nsis )
@@ -40,16 +30,18 @@ NSIS_VERSION := $(shell dpkg-query -f='$${Version}' -W nsis )
override_dh_auto_build:
ifeq ($(BYHAND),yes)
# Build the standalone+pxe version
+ # Don't allow non-Linux kernels, as their download is currently broken (see #819092)
STANDALONE=yes \
PXE=yes \
+ NOT_ALLKERNELS=yes \
OUTFILE_NAME=$(W32_BYHAND_NAME).exe \
BUILD_DATE="$(BUILD_DATE)" \
dh_auto_build
# Prepare the README file
- awk '{sub(/@PACKAGES_LIST@/,"$(PACKAGES_LIST)")}1 \
- {sub(/@NSIS_VERSION@/,"$(NSIS_VERSION)")}1 \
- {sub(/@W32_VERSION@/,"$(W32_VERSION)")}1' \
+ gawk '{sub(/@PACKAGES_LIST@/,"$(PACKAGES_LIST)")}1 \
+ {sub(/@NSIS_VERSION@/,"$(NSIS_VERSION)")}1 \
+ {sub(/@W32_VERSION@/,"$(W32_VERSION)")}1' \
debian/win32-loader_doc.txt > $(W32_BYHAND_NAME).txt
cat debian/copyright >> $(W32_BYHAND_NAME).txt
endif
diff --git a/debian/source/options b/debian/source/options
deleted file mode 100644
index 8581bf6..0000000
--- a/debian/source/options
+++ /dev/null
@@ -1,2 +0,0 @@
-# Compress source using bz2
-compression = bzip2