summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorJérémy Bobbio <lunar@debian.org>2015-04-29 09:13:35 +0200
committerDidier Raboud <odyx@debian.org>2015-04-29 09:13:35 +0200
commit559c2c9c005f56942d8581c6827b7be4fe036b0a (patch)
tree115a6e60406aa6363bd4abb406859afff671ae29 /debian
parent41fbb47b39e61fb2046da3fb45b4f4d2fbdb4ed7 (diff)
Reproducible build: Set build date in debian/rules to the latest debian/changelog entry
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules4
1 files changed, 4 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 0039893..352f819 100755
--- a/debian/rules
+++ b/debian/rules
@@ -3,6 +3,8 @@
# Install the win32-loader-standalone.exe as debian/tools/win32-loader/$(SUITE)/win32-loader.exe on the mirrors
BYHAND ?= yes
+BUILD_DATE := $(shell dpkg-parsechangelog -S Date)
+
W32_VERSION := $(shell dpkg-parsechangelog | sed -rne 's,^Version: ([^-]+).*,\1,p')
W32_BYHAND_NAME := win32-loader_$(W32_VERSION)_all
@@ -41,6 +43,7 @@ ifeq ($(BYHAND),yes)
STANDALONE=yes \
PXE=yes \
OUTFILE_NAME=$(W32_BYHAND_NAME).exe \
+ BUILD_DATE="$(BUILD_DATE)" \
dh_auto_build
# Prepare the README file
@@ -52,6 +55,7 @@ ifeq ($(BYHAND),yes)
endif
# Build the cdrom version
OUTFILE_NAME=win32-loader.exe \
+ BUILD_DATE="$(BUILD_DATE)" \
dh_auto_build
override_dh_auto_clean: