summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorDidier Raboud <odyx@debian.org>2017-03-20 21:14:40 +0100
committerDidier Raboud <odyx@debian.org>2017-03-20 21:14:54 +0100
commiteeef4ef7d5a5a5b00048f2fdc8b359e884cba74c (patch)
tree750a70601bd7020607b1eaca3184f44f3d3caf44 /debian
parent4b2d5d04b456390e7642db7b01639960880a7e93 (diff)
Fix dpkg-query calls to use source:* for Version and Package directly
Add Build-Dependency on dpkg (>= 1.16.2) for that support. Fixes the FTBFS revealed by loadlin's binNMU. Closes: #858104
Diffstat (limited to 'debian')
-rw-r--r--debian/control1
-rwxr-xr-xdebian/rules14
2 files changed, 3 insertions, 12 deletions
diff --git a/debian/control b/debian/control
index 829595a..1eb204c 100644
--- a/debian/control
+++ b/debian/control
@@ -4,6 +4,7 @@ Priority: extra
Maintainer: Debian Install System Team <debian-boot@lists.debian.org>
Uploaders: Robert Millan <rmh.debian@aybabtu.com>, Didier Raboud <odyx@debian.org>, Christian Perrier <bubulle@debian.org>
Build-Depends:
+ dpkg (>= 1.16.2),
debhelper (>= 9),
nsis (>= 2.48), nsis-pluginapi,
mingw-w64,
diff --git a/debian/rules b/debian/rules
index 8926a14..f9367f9 100755
--- a/debian/rules
+++ b/debian/rules
@@ -13,23 +13,13 @@ B_D_PACKAGES := grub-pc-bin cpio-win32 gzip-win32 gpgv-win32 debian-archive-keyr
PACKAGES_LIST := $(shell set -e; \
for p in ${B_D_PACKAGES}; \
do \
- if test `dpkg-query --showformat='x$${Source}x' --show $$p` = "xx"; \
- then \
- dpkg-query --showformat='$${Package;-25} $${Version;-25} http://ftp.debian.org/debian/pool/main/$${Package;1}/$${Package}\\n' --show $$p; \
- else \
- dpkg-query --showformat='$${Package;-25} $${Version;-25} http://ftp.debian.org/debian/pool/main/$${Source;1}/$${Source}\\n' --show $$p; \
- fi; \
+ dpkg-query --showformat='$${source:Package;-25} $${source:Version;-25} http://ftp.debian.org/debian/pool/main/$${source:Package;1}/$${source:Package}\\n' --show $$p; \
done)
BUILT_USING_LIST := $(shell set -e; \
for p in ${B_D_PACKAGES}; \
do \
- if test `dpkg-query --showformat='x$${Source}x' --show $$p` = "xx"; \
- then \
- dpkg-query --showformat='$${Package} (= $${Version}), ' --show $$p; \
- else \
- dpkg-query --showformat='$${Source} (= $${Version}), ' --show $$p; \
- fi; \
+ dpkg-query --showformat='$${source:Package} (= $${source:Version}), ' --show $$p; \
done)
NSIS_VERSION := $(shell dpkg-query -f='$${Version}' -W nsis )