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Convert your videos quickly, easily, and all at once with WinFF and FFmpeg.

Introduction
WinFF is a GUI for the command line video converter, FFMPEG. It will convert most any video 

file that FFmpeg will convert. For example: you can convert your camera, phone, and internet 
videos into videos for multiple phones, websites, and media players. 

WinFF is free software: you can redistribute it and/or modify it under the terms of the GNU
General Public License as published by the Free Software Foundation, either version 3 of the 

License, or any later version. Copies of the latest and previous source code archives are available at 
WinFF.org.

WinFF is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY;
without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR

PURPOSE. See the GNU General Public License for more details.

FFmpeg is a separate project, not connected to WinFF. “FFmpeg is a complete, cross-platform
solution to record, convert and stream audio and video. It includes libavcodec - the leading 

audio/video codec library.” FFmpeg is a Trademark of Fabrice Bellard, originator of the FFmpeg 
project. Ffmpeg is free software and is licensed under the LGPL or GPL. Specifically in the case of 
versions of Ffmpeg packaged with WinFF, FFmpeg is licensed under the GPL. Complete FFmpeg 

documentation and sources are available Ffmpeg.org

http://ffmpeg.org/


Using WinFF for the First Time.

After installing WinFF, Open WinFF. You will see the main window. At the top are the Buttons. 
Below them is the File List. Next is the Options.

The first thing to do is select the format you wish for your videos. In the Option Deteails, you will 
see Convert To. For example you may wish to convert your video to MPEG4 or Google Android. 
You can choose Audio if you are converting audio files. You can also convert videos file to audio 
files. 

Next is the Preset (Preset Configurations). If you chose MPEG4, you may choose Mpeg4 720p. You 
may also choose Full Screen or Widescreen, as apropriate.

Then is the Output Folder (or destination directory). This is where you wish to put your converted 
videos. You may also check the Use Source box to use the folder that the video files are in.

To add your videos, click the Add button. Browse to the videos you wish to convert. You can select 
multiple videos at one time. You can also drag and drop your videos files on to the WinFF window. 
If you add the wrong video you can click on the video and click the Remove button. To remove all 
the videos in the File List, click the Clear button.

To play a movie, click the Play button.

To preview a video you wish to convert, click the Preview button. The Preview button will convert 
one minute of you video and play it. Some video conversions will take a long time depending each 
video, the number of videos, the format chosen, and your computer. You may wish to preview a 
video before converting them all.

To start the conversion, click the Convert button. A Command Window will open. FFmpeg will start 
converting. It is not important to know what FFmpeg is doing. Advanced users will be able to 
interput the output. Even if errors are reported, the video(s) may play fine. You can find more 
information about the output in the FFmpeg Documention. You may close the WinFF window at 
this point. FFmpeg will continue converting. When the video(s) are done converting you will see, 
"Press any key to continue." After pressing a key the command window will close.

You videos are now converted. Not all videos will convert all the time. You should check the videos 
for errors.

Selecting Options for Videos

You can select different presets and options for different videos. You can convert some videos to 
one format, and others to other formats.

To select a video(s) click the video(s) in the File List. The options will change to the options of the 
current video. You can then change Convert To, Preset, and Output Folder for the video(s). Cancel 
Changes, Apply Changes, and Apply to All will then appear at the bottom of the WinFF main 
window. Click Apply Changes to apply the changes.

Click the Options Button to show the additional options. You will see new tabs next to the Output 



Folder Tab.

Clicking the Video tab will show the video options. You can change the Video Bitrate, Frame Rate, 
Video Size, Aspect Ratio, and Rotate the Video. The 2Pass check box will run Ffmpeg twice on the 
same video. Sometimes this will increase the quality of the final video(s). Deinterlace will make the 
video progressive as in 720p compared to 480i.

The audio tab shows the Audio Bitrate, Sample Rate, Audio Channels, Volume, and Sync. The Crop 
tab will allow you to crop the video. The time tab allows you to convert portions of a video. 

The FFmpeg tab allows you to change the Ffmpeg command line. Additional Command Line 
Paramters allows advanced users to add parameters to Ffmpeg. The first and second pass allows 
parameters to be added to each respectively.

After changing the options, always remeber to click Apply Changes before choosing other files.

Navigating the Menus

Under the File Menu is Import Preset and Exit. 

• Preset files are ".wff" files. The containe one or more preset configurations for 
various uses and devices. Depending on your operating system you may be able to 
just double click the preset file to import it in to WinFF. 

• Of course Exit, exits WinFF.

Under the Edit menu is Presets and Preferences. 

• Editing the Presets will allow you to change the presets or create new presets.

•  Editing the Preferences will allow to change various things about WinFF's behavior.

• Both editing the Presets and the Preferences are addressed further in this document.

Under the Options Menu is Additional Options, Display CMD Line, Pause on Finish, Shutdown on 
Finish, and Save Options to Preset. 

• Additional Options will show or hide the Options, just as the Options button does.

•  Display CMD Line will show a window that allows you to edit the script that WinFF 
creates to run Ffmpeg.

•  Pause on Finish will display the, "Press any key to continue." at the end of the 
conversion. Unchecking Pause on Finish will close the command window 
automaticly at the end of conversion.

•  Shutdown on Finish will shut down the computer at the end of conversion. Some 
operating systems have problems with shutting down, especially older versions of 
windows.

• Save to Presets will save the current options to the currently selected preset. For 
example you may change the the MPEG4 preset to the options required for your 
phone, without editing the preset.

Under the Help menu you can open



• this documentation

• the WinFF website

• the mailing list

• the credits.

Editing the Presets
The presets editor is open by choosing “Presets” from the Edit menu. Once open you will see
the list of presets. Clicking a Preset will fill the boxes below with the selected preset's information.

The Preset Name is an internal name used in the xml file.
● It must follow all the rules of an XML tag name.

● Namely, one word, only letters and numbers.

● If the preset name is the same as another preset the existing preset will be replaced

    by the current information.

The Preset Label is the label shown in the list of presets shown on the main window

● It may contain any characters you wish.

● It should be descriptive.

● About 40 characters max visible. Extra will be shown as “...”

The Commandline Parameters are the FFmpeg parameters for the preset.

● The params will be specified after “-i inputfile” and before the output filename.

● Spacing of params should be the same as if the were typed into the command line.

● Spacing before and after the params will be handled automatically

● Do not specify the input or output file names.

● Existing Presets are great examples.

The Preset Extension is the file extension of the output files.

● This also specifies the container format for the file.

● Use “-f “ in the params to force a particular format.

The Preset Category is the Category for the Preset to be shown in.

● To create a new category, just type a new name.

● To use an existing category, enter the category.

The Add/Update button adds or updates the current preset.

● You will be asked to confirm the addition or update.

● Once a preset is added it will be available in the main window but is not saved to disk



    until the SAVE button is pressed.

The Delete button deletes the current preset.

The Save button saves the presets to presets.xml

The Close button closes the preset editor.

● Closes the window but does not save

● Preset changes are available in the main window, but not saved.

● If you have not saved, the next time WinFF is started the presets will revert.

The Import Button imports presets from a file.

● Name and Label must be unique or you will be asked to replace the preset.

● WinFF presets are saved as “.wff” files

● When importing if a preset already exists, WinFF will ask to replace it.

The Export button exports presets to a file

● Select the presets to export from the list.

● WinFF presets are saved as “.wff”

● .wff files are the same format as the main presets file

Preferences

General Preferences

The Default Directory is the directory that will be set as the destination directory at start up. If

Remember Last is checked then WinFF will remember the destination directory from the last time it

was ran.

Remember Last Directory Used will set the output folder to the last folder before WinFF was 
closed.

Use Several Encoding Threads uses FFmpeg's -threads parameter. It work on some

codecs but not all and the codecs it works on is various in Windows and Linux. Two, four, and eight 
would be used for dual core, quadcore, eight-core processors.

Priority is the priority for the FFmpeg process when converting. Setting to high will use all

resources available to get done faster. Setting the Priority to Idle will only convert when the 
computer is doing nothing. In Linux a user is not allowed to set a priority higher than normal. So 



setting the priority to high will have no effect, unless WinFF is ran as root, which is not advisable.

Preferences For Windows
First things first: If WinFF is running under Windows the Linux/Unix tab is completely 
nonfunctional.

Don't worry about screwing anything up, cause it just won't happen.

The path to FFmpeg.exe is the full path to ffmpeg. Such as:

“C:\Program Files\WinFF\winff.exe”

You may change this to any location you have installed FFmpeg.exe. If you leave this blank, WinFF

will automatically revert to the location of WinFF.exe and assume FFmpeg.exe is in the same 
directory. The path to ffplay.exe functions exactly like the path to ffmpeg.exe, except it should point 
to ffplay.exe.

Use CHCP for international characters set the code page for the command prompt with the

system setting. The CHCP command arbitrarily crashes on later versions of XP and Vista. If this is 
the case you can turn it off by unchecking the box for it. If it is unchecked though you will need to 
remove non ANSI characters from file names of the videos to be converted.

Preferences For Unix/Linux
Vice versa to Windows: If WinFF is running under Linux or another flavor of Unix. The Windows 
tab is completely non-functional. Don't worry about screwing anything up, cause it just won't 
happen.

The Path to FFmpeg is the full path to FFmpeg. Such as “/usr/bin/ffmpeg” You may change this to 
any location you have installed FFmpeg. The first time WinFF is ran, and anytime there after that 
“~/.winff/cfg.xml” is not found (such as the user deleting it), WinFF will look for FFmpeg in 
“/usr/bin” and “/usr/local/bin”. 

The Path to FFplay functions exactly like the path to FFmpeg, except it should point to

FFplay.

The Terminal to Use is the full path to the terminal you wish to use. WinFF defaults to Xterm

as almost all X-windows systems have Xterm installed. On Debian/Ubuntu based systems, WinFF 
use the x-term-emulator symbolic link. You may use any terminal you like by specifying it's full 
path here. For example, to use Gnome-terminal under Ubuntu, you could specify this to be 
“/usr/bin/gnometerminal”, and specify the Terminal Options as “-x” instead of “-e”. To use Xterm 
under Slackware, this should be “/usr/X11R6/bin/xterm”. 

The Terminal Options can be anything you like, but must include as the last option, the option to 
execute the remainder of the command line. Again for example, Xterm uses “-e”, and Gnome-
Terminal uses “-x”.



Further Reading
For more help please see the documentation page at WinFF.org or the WinFF Mailing List.

For more in depth information on the FFmpeg command line please see http://ffmpeg.org/ffmpeg-
doc.html. It contains the entire list of options and formats the can be set using FFmpeg. Googling 
for FFmpeg and the format will give you some examples. Also existing presets will give you some 
good example of what should be specified.
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