summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRémi Vanicat <vanicat@debian.org>2020-01-13 17:26:13 +0100
committerRémi Vanicat <vanicat@debian.org>2020-01-13 17:26:13 +0100
commit03a91d7740bd67645dfd83d5642ea255a8d192a7 (patch)
tree45520f8de1d08294df731d982048995f2faf4c25
parent1166e9ac4c217f2de61ab019bbb3af43a19c6cd2 (diff)
parent982daf6c85cefbaa3b805cc50c4f5b4c207201fe (diff)
Update upstream source from tag 'upstream/2.9.1'
-rw-r--r--.travis.yml2
-rw-r--r--Makefile2
-rw-r--r--htmlxref.cnf42
-rw-r--r--with-editor.el52
-rw-r--r--with-editor.org12
-rw-r--r--with-editor.texi10
6 files changed, 90 insertions, 30 deletions
diff --git a/.travis.yml b/.travis.yml
index 3cffd21..c3f5509 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,4 +1,4 @@
-sudo: false
+dist: xenial # Explicitly ask for the new default.
language: generic
env:
global:
diff --git a/Makefile b/Makefile
index 5dda1ce..a0af182 100644
--- a/Makefile
+++ b/Makefile
@@ -135,6 +135,8 @@ release: html html-dir pdf
@aws s3 cp $(PKG).html $(RELEASE_TARGET)
@aws s3 cp $(PKG).pdf $(RELEASE_TARGET)
@aws s3 sync --delete $(PKG) $(RELEASE_TARGET)$(PKG)/
+ @aws s3 cp $(PUBLISH_TARGET)dir.html $(RELEASE_TARGET)dir.html
+ @aws s3 cp $(PUBLISH_TARGET)dir/index.html $(RELEASE_TARGET)dir/index.html
@printf "Generating CDN invalidation\n"
@aws cloudfront create-invalidation --distribution-id $(CFRONT_DIST) --paths \
"$(subst $(space),$(comma),$(addprefix $(RELEASE_PATH),$(CFRONT_PATHS)))" > /dev/null
diff --git a/htmlxref.cnf b/htmlxref.cnf
new file mode 100644
index 0000000..54c3421
--- /dev/null
+++ b/htmlxref.cnf
@@ -0,0 +1,42 @@
+# https://www.gnu.org/software/texinfo/manual/texinfo/html_node/HTML-Xref-Configuration.html
+
+EMACS = https://www.gnu.org/software/emacs/manual
+
+auth mono ${EMACS}/html_mono/auth.html
+auth node ${EMACS}/html_node/auth/
+
+ediff mono ${EMACS}/html_mono/ediff.html
+ediff node ${EMACS}/html_node/ediff/
+
+elisp mono ${EMACS}/html_mono/elisp.html
+elisp node ${EMACS}/html_node/elisp/
+
+emacs mono ${EMACS}/html_mono/emacs.html
+emacs node ${EMACS}/html_node/emacs/
+
+
+MAGIT = https://magit.vc/manual
+
+forge mono ${MAGIT}/forge.html
+forge node ${MAGIT}/forge/
+
+ghub mono ${MAGIT}/ghub.html
+ghub node ${MAGIT}/ghub/
+
+magit mono ${MAGIT}/magit.html
+magit node ${MAGIT}/magit/
+
+transient mono ${MAGIT}/transient.html
+transient node ${MAGIT}/transient/
+
+with-editor mono ${MAGIT}/with-editor.html
+with-editor node ${MAGIT}/with-editor/
+
+
+MIRROR = https://emacsmirror.net/manual
+
+borg mono ${MAGIT}/borg.html
+borg node ${MAGIT}/borg/
+
+epkg mono ${MAGIT}/epkg.html
+epkg node ${MAGIT}/epkg/
diff --git a/with-editor.el b/with-editor.el
index 906d8e3..7612200 100644
--- a/with-editor.el
+++ b/with-editor.el
@@ -1,6 +1,6 @@
;;; with-editor.el --- Use the Emacsclient as $EDITOR -*- lexical-binding: t -*-
-;; Copyright (C) 2014-2019 The Magit Project Contributors
+;; Copyright (C) 2014-2020 The Magit Project Contributors
;;
;; You should have received a copy of the AUTHORS.md file. If not,
;; see https://github.com/magit/with-editor/blob/master/AUTHORS.md.
@@ -86,7 +86,10 @@
(require 'shell)
(and (require 'async-bytecomp nil t)
- (memq 'magit (bound-and-true-p async-bytecomp-allowed-packages))
+ (let ((pkgs (bound-and-true-p async-bytecomp-allowed-packages)))
+ (if (consp pkgs)
+ (cl-intersection '(all magit) pkgs)
+ (memq pkgs '(all t))))
(fboundp 'async-bytecomp-package-mode)
(async-bytecomp-package-mode 1))
@@ -207,7 +210,7 @@ performant implementation:
trap \\\"exit 1\" USR2; \\
while true; do sleep 1; done'\"
-Note that the unit seperator character () right after the file
+Note that the unit separator character () right after the file
name ($0) is required.
Also note that using this alternative implementation leads to a
@@ -340,7 +343,7 @@ And some tools that do not handle $EDITOR properly also break."
(with-temp-buffer
(setq default-directory dir)
(setq-local with-editor-post-finish-hook post-finish-hook)
- (when (bound-and-true-p git-commit-post-finish-hook)
+ (when post-commit-hook
(setq-local git-commit-post-finish-hook post-commit-hook))
(run-hooks 'with-editor-post-finish-hook)))))
@@ -432,23 +435,36 @@ And some tools that do not handle $EDITOR properly also break."
(put 'with-editor-mode 'permanent-local t)
(defun with-editor-kill-buffer-noop ()
- (if (memq this-command '(save-buffers-kill-terminal
- save-buffers-kill-emacs))
- (let ((with-editor-cancel-query-functions nil))
- (with-editor-cancel nil)
- t)
- (user-error (substitute-command-keys "\
-Don't kill this buffer. Instead cancel using \\[with-editor-cancel]"))))
+ ;; We started doing this in response to #64, but it is not safe
+ ;; to do so, because the client has already been killed, causing
+ ;; `with-editor-return' (called by `with-editor-cancel') to delete
+ ;; the file, see #66. The reason we delete the file in the first
+ ;; place are https://github.com/magit/magit/issues/2258 and
+ ;; https://github.com/magit/magit/issues/2248.
+ ;; (if (memq this-command '(save-buffers-kill-terminal
+ ;; save-buffers-kill-emacs))
+ ;; (let ((with-editor-cancel-query-functions nil))
+ ;; (with-editor-cancel nil)
+ ;; t)
+ ;; ...)
+ ;; So go back to always doing this instead:
+ (user-error (substitute-command-keys (format "\
+Don't kill this buffer %S. Instead cancel using \\[with-editor-cancel]"
+ (current-buffer)))))
+
+(defvar-local with-editor-usage-message "\
+Type \\[with-editor-finish] to finish, \
+or \\[with-editor-cancel] to cancel")
(defun with-editor-usage-message ()
;; Run after `server-execute', which is run using
;; a timer which starts immediately.
- (run-with-timer
- 0.01 nil `(lambda ()
- (with-current-buffer ,(current-buffer)
- (message (substitute-command-keys "\
-Type \\[with-editor-finish] to finish, \
-or \\[with-editor-cancel] to cancel"))))))
+ (let ((buffer (current-buffer)))
+ (run-with-timer
+ 0.05 nil
+ (lambda ()
+ (with-current-buffer buffer
+ (message (substitute-command-keys with-editor-usage-message)))))))
;;; Wrappers
@@ -566,7 +582,7 @@ the appropriate editor environment variable."
(defun with-editor-set-process-filter (process filter)
"Like `set-process-filter' but keep `with-editor-process-filter'.
Give PROCESS the new FILTER but keep `with-editor-process-filter'
-if that was added earlier by the adviced `start-file-process'.
+if that was added earlier by the advised `start-file-process'.
Do so by wrapping the two filter functions using a lambda, which
becomes the actual filter. It calls `with-editor-process-filter'
diff --git a/with-editor.org b/with-editor.org
index f1f1433..3e51df2 100644
--- a/with-editor.org
+++ b/with-editor.org
@@ -2,13 +2,13 @@
:PREAMBLE:
#+AUTHOR: Jonas Bernoulli
#+EMAIL: jonas@bernoul.li
-#+DATE: 2015-2019
+#+DATE: 2015-2020
#+LANGUAGE: en
#+TEXINFO_DIR_CATEGORY: Emacs
#+TEXINFO_DIR_TITLE: With-Editor: (with-editor).
#+TEXINFO_DIR_DESC: Using the Emacsclient as $EDITOR
-#+SUBTITLE: for version 2.8.3
+#+SUBTITLE: for version 2.9.1
#+TEXINFO_DEFFN: t
#+PROPERTY: header-args :eval never
@@ -32,10 +32,10 @@ additional functionality which makes it useful even for end-users, who
don't use Magit or another package which uses it internally.
#+TEXINFO: @noindent
-This manual is for With-Editor version 2.8.3.
+This manual is for With-Editor version 2.9.1.
#+BEGIN_QUOTE
-Copyright (C) 2015-2019 Jonas Bernoulli <jonas@bernoul.li>
+Copyright (C) 2015-2020 Jonas Bernoulli <jonas@bernoul.li>
You can redistribute this document and/or modify it under the terms
of the GNU General Public License as published by the Free Software
@@ -143,7 +143,7 @@ it receives a signal.
while true; do sleep 1; done'"
#+END_SRC
- Note that the unit seperator character () right after the file
+ Note that the unit separator character () right after the file
name ($0) is required.
Also note that using this alternative implementation leads to a
@@ -298,7 +298,7 @@ Emacs and what is the output of ~M-x with-editor-debug RET~.
:END:
#+BEGIN_QUOTE
-Copyright (C) 2015-2019 Jonas Bernoulli <jonas@bernoul.li>
+Copyright (C) 2015-2020 Jonas Bernoulli <jonas@bernoul.li>
You can redistribute this document and/or modify it under the terms
of the GNU General Public License as published by the Free Software
diff --git a/with-editor.texi b/with-editor.texi
index 793c6cb..542004d 100644
--- a/with-editor.texi
+++ b/with-editor.texi
@@ -8,7 +8,7 @@
@copying
@quotation
-Copyright (C) 2015-2019 Jonas Bernoulli <jonas@@bernoul.li>
+Copyright (C) 2015-2020 Jonas Bernoulli <jonas@@bernoul.li>
You can redistribute this document and/or modify it under the terms
of the GNU General Public License as published by the Free Software
@@ -31,7 +31,7 @@ General Public License for more details.
@finalout
@titlepage
@title With-Editor User Manual
-@subtitle for version 2.8.3
+@subtitle for version 2.9.1
@author Jonas Bernoulli
@page
@vskip 0pt plus 1filll
@@ -60,10 +60,10 @@ additional functionality which makes it useful even for end-users, who
don't use Magit or another package which uses it internally.
@noindent
-This manual is for With-Editor version 2.8.3.
+This manual is for With-Editor version 2.9.1.
@quotation
-Copyright (C) 2015-2019 Jonas Bernoulli <jonas@@bernoul.li>
+Copyright (C) 2015-2020 Jonas Bernoulli <jonas@@bernoul.li>
You can redistribute this document and/or modify it under the terms
of the GNU General Public License as published by the Free Software
@@ -198,7 +198,7 @@ trap \"exit 1\" USR2; \
while true; do sleep 1; done'"
@end lisp
-Note that the unit seperator character () right after the file
+Note that the unit separator character () right after the file
name ($0) is required.
Also note that using this alternative implementation leads to a