summaryrefslogtreecommitdiff
path: root/etc/debian-menu-system/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'etc/debian-menu-system/Makefile.am')
-rw-r--r--etc/debian-menu-system/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/etc/debian-menu-system/Makefile.am b/etc/debian-menu-system/Makefile.am
new file mode 100644
index 0000000..c014cf5
--- /dev/null
+++ b/etc/debian-menu-system/Makefile.am
@@ -0,0 +1,27 @@
+## Process this file with automake to produce Makefile.in
+## You probably want to run automake from the top-level directory, though
+## Makefile.am for subdirectories of wm-icons package
+## Copyright 1999, Julian Gilbey <jdg@debian.org>
+## This file may be copied under the conditions of the GNU General
+## Public License, version 2 or later. NO warranty of any kind is
+## given.
+
+AUTOMAKE_OPTIONS = foreign
+
+configdir = @datadir@/wm-icons/debian-menu-system
+
+config_DATA = wm-icons.h wm-icons-data.h wm-icons-fvwm2rc-menu README
+
+EXTRA_DIST = wm-icons.h.in wm-icons-data.h.in wm-icons-fvwm2rc-menu.in
+
+CLEANFILES = wm-icons.h wm-icons-data.h wm-icons-fvwm2rc-menu
+
+SUFFIXES = .in
+
+at = @
+
+editex = sed -e 's,$(at)icondir@,$(icondir),g' -e 's,$(at)userdir@,$(userdir),g'
+
+.in:
+ rm -f $@ $@.tmp
+ $(editex) $< > $@.tmp && mv $@.tmp $@