summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Shadura <andrew@shadura.me>2014-11-25 02:01:30 +0100
committerAndrew Shadura <andrew@shadura.me>2014-11-25 02:01:30 +0100
commit325e2ef26b9bf6f8cb90b6093319c2905786bdca (patch)
treea0839a882f691c258f4955d78302a70706f99769
parent9af1e8a0a934729e07effb7560f7a0427fec9ea5 (diff)
Fix Mod4-a combination by doing stat on /keys (thanks to
Thierry Rascle, closes: #713863).
-rw-r--r--debian/changelog7
-rw-r--r--debian/patches/20-fix-mod4-a.patch23
-rw-r--r--debian/patches/series1
3 files changed, 31 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index a678091..06f7aca 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+wmii (3.10~20120413+hg2813-8) unstable; urgency=medium
+
+ * Fix Mod4-a combination by doing stat on /keys (thanks to
+ Thierry Rascle, closes: #713863).
+
+ -- Andrew Shadura <andrewsh@debian.org> Mon, 24 Nov 2014 20:34:37 +0100
+
wmii (3.10~20120413+hg2813-7) unstable; urgency=medium
* Tweaks to the build system.
diff --git a/debian/patches/20-fix-mod4-a.patch b/debian/patches/20-fix-mod4-a.patch
new file mode 100644
index 0000000..83dd6fb
--- /dev/null
+++ b/debian/patches/20-fix-mod4-a.patch
@@ -0,0 +1,23 @@
+From: Thierry Rascle <thierr26@free.fr>
+Subject: stat /keys automatically.
+
+--- wmii-3.10~20120413+hg2813.orig/cmd/wmiir.c 2012-04-14 04:37:30.000000000 +0200
++++ wmii-3.10~20120413+hg2813/cmd/wmiir.c 2013-06-23 11:49:13.600784471 +0200
+@@ -529,6 +529,7 @@
+ char *address;
+ exectab *tab;
+ int ret;
++ Stat *stat;
+
+ IXP_ASSERT_VERSION;
+
+@@ -579,6 +580,9 @@
+ if(tab->cmd == 0)
+ usage();
+
++ stat = ixp_stat(client, "/keys");
++ ixp_freestat(stat);
++
+ ret = tab->fn(argc, argv);
+
+ ixp_unmount(client);
diff --git a/debian/patches/series b/debian/patches/series
index 990062e..21a4d07 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -9,6 +9,7 @@
16-fix-confdir.patch
16-fix-notice-command.patch
17-fix-multimonitor-witray.patch
+20-fix-mod4-a.patch
20-libixp-link.patch
23-buildsys-tweaks.patch
24-fix-focus.patch