summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Shadura <bugzilla@tut.by>2013-04-14 14:04:55 +0200
committerAndrew Shadura <bugzilla@tut.by>2013-04-14 14:04:55 +0200
commite5d10528224d7b15cfcc02729c0f5322fee58182 (patch)
treeef0fe904e1b340d5d72109c7ddbdc804785d990b
parent47288c368f6619cfa059fc68ddbb6e2309d592a5 (diff)
Fix FTBFS on Hurd and kFreeBSD.
Update the changelog.
-rw-r--r--debian/changelog10
-rw-r--r--debian/patches/10-hostname.patch28
2 files changed, 37 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index e85ccb6..3f39e4d 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+wmii (3.10~20120413+hg2813-2) experimental; urgency=low
+
+ * Provide HOST_NAME_MAX on systems not having it (fixes FTBFS on
+ kFreeBSD and Hurd).
+
+ -- Andrew Shadura <andrewsh@debian.org> Sat, 13 Apr 2013 09:37:36 +0200
+
wmii (3.10~20120413+hg2813-1) experimental; urgency=low
* New maintainer (Closes: #606084).
@@ -16,8 +23,9 @@ wmii (3.10~20120413+hg2813-1) experimental; urgency=low
* Added doc-base registration file.
* Make the Unicode font default (Closes: #598630).
* Remove an alternative dependency on dwm-tools.
+ * Build-depend on python-all to ensure dh_python2 is available.
- -- Andrew Shadura <andrewsh@debian.org> Fri, 12 Apr 2013 21:16:26 +0200
+ -- Andrew Shadura <andrewsh@debian.org> Fri, 12 Apr 2013 21:43:51 +0200
wmii (3.9.2+debian-4) unstable; urgency=low
diff --git a/debian/patches/10-hostname.patch b/debian/patches/10-hostname.patch
new file mode 100644
index 0000000..a52b45f
--- /dev/null
+++ b/debian/patches/10-hostname.patch
@@ -0,0 +1,28 @@
+Subject: Provide a fake HOST_NAME_MAX on systems not having it.
+
+--- a/lib/libstuff/x11/windows/createwindow_visual.c
++++ b/lib/libstuff/x11/windows/createwindow_visual.c
+@@ -5,6 +5,10 @@
+ #include <string.h>
+ #include <unistd.h>
+
++#ifndef HOST_NAME_MAX
++#define HOST_NAME_MAX 255
++#endif
++
+ static char hostname[HOST_NAME_MAX + 1];
+ static long pid;
+
+--- a/cmd/wmii/dat.h
++++ b/cmd/wmii/dat.h
+@@ -18,6 +18,10 @@
+ #include <stuff/util.h>
+ #include "debug.h"
+
++#ifndef HOST_NAME_MAX
++#define HOST_NAME_MAX 255
++#endif
++
+ #define FONT "-*-fixed-medium-r-*-*-*-120-75-75-c-60-iso10646-"
+ #define FOCUSCOLORS "#000000 #81654f #000000"
+ #define NORMCOLORS "#000000 #c1c48b #81654f"