summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorReiner Herrmann <reiner@reiner-h.de>2017-11-10 17:24:01 +0100
committerAndrew Shadura <andrew.shadura@collabora.co.uk>2017-11-24 14:47:50 +0000
commit42460c39c275699e93c1833d0b13384b00728765 (patch)
tree517f85ede1725db5d37cd882137beedceb973820
parent48a1ab860bf9184dc2676dfcfcaa9b300fad75e6 (diff)
Port wpa_gui to Qt5
Closes: #875233
-rw-r--r--debian/control5
-rwxr-xr-xdebian/rules7
2 files changed, 6 insertions, 6 deletions
diff --git a/debian/control b/debian/control
index c9a4aa0..988ac8b 100644
--- a/debian/control
+++ b/debian/control
@@ -9,7 +9,7 @@ Priority: optional
Build-Depends: debhelper (>> 9.20120115),
libdbus-1-dev,
libssl-dev,
- libqt4-dev,
+ qtbase5-dev,
libncurses5-dev,
libpcsclite-dev,
libnl-3-dev [linux-any],
@@ -19,7 +19,6 @@ Build-Depends: debhelper (>> 9.20120115),
libbsd-dev [kfreebsd-any],
libreadline-dev,
pkg-config,
- qt4-qmake,
docbook-to-man,
docbook-utils
Standards-Version: 3.9.6
@@ -60,7 +59,7 @@ Multi-Arch: foreign
Depends: ${shlibs:Depends},
${misc:Depends},
wpasupplicant (>= 0.7.3~),
- libqt4-svg
+ libqt5svg5
Recommends: menu
Description: graphical user interface for wpa_supplicant
wpagui provides a Qt interface for choosing which configured network
diff --git a/debian/rules b/debian/rules
index bec85a7..95a5b41 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,5 +1,6 @@
#!/usr/bin/make -f
+export QT_SELECT=qt5
export DEB_BUILD_MAINT_OPTIONS=hardening=+all
include /usr/share/dpkg/buildflags.mk
@@ -32,7 +33,7 @@ VERSION := $(shell dpkg-parsechangelog | sed -ne 's,^Versi
### start dh overrides
override_dh_auto_configure:
dh_auto_configure --sourcedirectory=wpa_supplicant/wpa_gui-qt4 \
- --buildsystem=qmake_qt4
+ --buildsystem=qmake
override_dh_auto_build:
# build documentation
@@ -55,7 +56,7 @@ override_dh_auto_build:
--parallel
# build wpa_gui-qt4
dh_auto_build --sourcedirectory=wpa_supplicant/wpa_gui-qt4 \
- --buildsystem=qmake_qt4 \
+ --buildsystem=qmake \
--parallel
dh_auto_clean --sourcedirectory=src --buildsystem=makefile
# build hostapd
@@ -71,7 +72,7 @@ override_dh_auto_clean:
dh_auto_clean --sourcedirectory=wpa_supplicant \
--buildsystem=makefile
dh_auto_clean --sourcedirectory=wpa_supplicant/wpa_gui-qt4 \
- --buildsystem=qmake_qt4
+ --buildsystem=qmake
-find wpa_supplicant/wpa_gui-qt4 -type d -name \.moc -exec rm -rf {} \;
-find wpa_supplicant/wpa_gui-qt4 -type d -name \.ui -exec rm -rf {} \;
-find wpa_supplicant/wpa_gui-qt4 -type d -name \.obj -exec rm -rf {} \;