summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog9
-rw-r--r--debian/patches/CVE-2018-14526/rebased-v2.6-0001-WPA-Ignore-unauthenticated-encrypted-EAPOL-Key-data.patch44
-rw-r--r--debian/patches/nl80211-Fix-NL80211_ATTR_SMPS_MODE-encoding.patch32
-rw-r--r--debian/patches/series2
-rw-r--r--src/drivers/driver_nl80211.c2
-rw-r--r--src/rsn_supp/wpa.c11
6 files changed, 99 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 13c520d..47e0d7d 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,12 @@
+wpa (2:2.6-18) unstable; urgency=high
+
+ * Fix NL80211_ATTR_SMPS_MODE encoding (Closes: #903952)
+ * SECURITY UPDATE:
+ - CVE-2018-14526: Ignore unauthenticated encrypted EAPOL-Key data
+ (Closes: #905739)
+
+ -- Andrej Shadura <andrewsh@debian.org> Wed, 08 Aug 2018 22:50:11 +0200
+
wpa (2:2.6-17) unstable; urgency=medium
* Fix get-orig-source so that it can produce pre-release snapshots.
diff --git a/debian/patches/CVE-2018-14526/rebased-v2.6-0001-WPA-Ignore-unauthenticated-encrypted-EAPOL-Key-data.patch b/debian/patches/CVE-2018-14526/rebased-v2.6-0001-WPA-Ignore-unauthenticated-encrypted-EAPOL-Key-data.patch
new file mode 100644
index 0000000..a62b52c
--- /dev/null
+++ b/debian/patches/CVE-2018-14526/rebased-v2.6-0001-WPA-Ignore-unauthenticated-encrypted-EAPOL-Key-data.patch
@@ -0,0 +1,44 @@
+From 3e34cfdff6b192fe337c6fb3f487f73e96582961 Mon Sep 17 00:00:00 2001
+From: Mathy Vanhoef <Mathy.Vanhoef@cs.kuleuven.be>
+Date: Sun, 15 Jul 2018 01:25:53 +0200
+Subject: [PATCH] WPA: Ignore unauthenticated encrypted EAPOL-Key data
+
+Ignore unauthenticated encrypted EAPOL-Key data in supplicant
+processing. When using WPA2, these are frames that have the Encrypted
+flag set, but not the MIC flag.
+
+When using WPA2, EAPOL-Key frames that had the Encrypted flag set but
+not the MIC flag, had their data field decrypted without first verifying
+the MIC. In case the data field was encrypted using RC4 (i.e., when
+negotiating TKIP as the pairwise cipher), this meant that
+unauthenticated but decrypted data would then be processed. An adversary
+could abuse this as a decryption oracle to recover sensitive information
+in the data field of EAPOL-Key messages (e.g., the group key).
+(CVE-2018-14526)
+
+Signed-off-by: Mathy Vanhoef <Mathy.Vanhoef@cs.kuleuven.be>
+---
+ src/rsn_supp/wpa.c | 11 +++++++++++
+ 1 file changed, 11 insertions(+)
+
+diff -upr wpa_supplicant-2.6.orig/src/rsn_supp/wpa.c wpa_supplicant-2.6/src/rsn_supp/wpa.c
+--- wpa_supplicant-2.6.orig/src/rsn_supp/wpa.c 2016-10-02 21:51:11.000000000 +0300
++++ wpa_supplicant-2.6/src/rsn_supp/wpa.c 2018-08-08 16:55:11.506831029 +0300
+@@ -2016,6 +2016,17 @@ int wpa_sm_rx_eapol(struct wpa_sm *sm, c
+
+ if ((sm->proto == WPA_PROTO_RSN || sm->proto == WPA_PROTO_OSEN) &&
+ (key_info & WPA_KEY_INFO_ENCR_KEY_DATA)) {
++ /*
++ * Only decrypt the Key Data field if the frame's authenticity
++ * was verified. When using AES-SIV (FILS), the MIC flag is not
++ * set, so this check should only be performed if mic_len != 0
++ * which is the case in this code branch.
++ */
++ if (!(key_info & WPA_KEY_INFO_MIC)) {
++ wpa_msg(sm->ctx->msg_ctx, MSG_WARNING,
++ "WPA: Ignore EAPOL-Key with encrypted but unauthenticated data");
++ goto out;
++ }
+ if (wpa_supplicant_decrypt_key_data(sm, key, ver, key_data,
+ &key_data_len))
+ goto out;
diff --git a/debian/patches/nl80211-Fix-NL80211_ATTR_SMPS_MODE-encoding.patch b/debian/patches/nl80211-Fix-NL80211_ATTR_SMPS_MODE-encoding.patch
new file mode 100644
index 0000000..2cce04d
--- /dev/null
+++ b/debian/patches/nl80211-Fix-NL80211_ATTR_SMPS_MODE-encoding.patch
@@ -0,0 +1,32 @@
+From a2426829ce426de82d2fa47071ca41ea81c43307 Mon Sep 17 00:00:00 2001
+From: Jouni Malinen <jouni@qca.qualcomm.com>
+Date: Fri, 1 Dec 2017 20:22:44 +0200
+Subject: nl80211: Fix NL80211_ATTR_SMPS_MODE encoding
+
+This nl80211 attribute uses NLA_U8 policy in cfg80211 and
+hostapd/wpa_supplicant needs to use same size when writing the
+attribute.
+
+This fixes AP mode regression triggered by kernel commit "net: netlink:
+Update attr validation to require exact length for some types" in
+v4.15-rc1 that resulted in the following debug log entry when trying to
+enable beaconing:
+nl80211: Beacon set failed: -34 (Numerical result out of range)
+
+Fixes: da1080d7215f ("nl80211: Advertise and configure SMPS modes")
+Signed-off-by: Jouni Malinen <jouni@qca.qualcomm.com>
+---
+ src/drivers/driver_nl80211.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- a/src/drivers/driver_nl80211.c
++++ b/src/drivers/driver_nl80211.c
+@@ -3676,7 +3676,7 @@ static int wpa_driver_nl80211_set_ap(void *priv,
+ smps_mode = NL80211_SMPS_OFF;
+ break;
+ }
+- if (nla_put_u32(msg, NL80211_ATTR_SMPS_MODE, smps_mode))
++ if (nla_put_u8(msg, NL80211_ATTR_SMPS_MODE, smps_mode))
+ goto fail;
+ }
+
diff --git a/debian/patches/series b/debian/patches/series
index c3924d7..5e6bef5 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -26,3 +26,5 @@ fix-pem-decryption.patch
nl80211-Fix-race-condition-in-detecting-MAC-change.patch
wpa_supplicant-update-MAC-when-driver-detects-a-change.patch
dbus-available-sta.patch
+nl80211-Fix-NL80211_ATTR_SMPS_MODE-encoding.patch
+CVE-2018-14526/rebased-v2.6-0001-WPA-Ignore-unauthenticated-encrypted-EAPOL-Key-data.patch
diff --git a/src/drivers/driver_nl80211.c b/src/drivers/driver_nl80211.c
index 7547788..015fb1b 100644
--- a/src/drivers/driver_nl80211.c
+++ b/src/drivers/driver_nl80211.c
@@ -3676,7 +3676,7 @@ static int wpa_driver_nl80211_set_ap(void *priv,
smps_mode = NL80211_SMPS_OFF;
break;
}
- if (nla_put_u32(msg, NL80211_ATTR_SMPS_MODE, smps_mode))
+ if (nla_put_u8(msg, NL80211_ATTR_SMPS_MODE, smps_mode))
goto fail;
}
diff --git a/src/rsn_supp/wpa.c b/src/rsn_supp/wpa.c
index 2a53c6f..dcd7527 100644
--- a/src/rsn_supp/wpa.c
+++ b/src/rsn_supp/wpa.c
@@ -2072,6 +2072,17 @@ int wpa_sm_rx_eapol(struct wpa_sm *sm, const u8 *src_addr,
if ((sm->proto == WPA_PROTO_RSN || sm->proto == WPA_PROTO_OSEN) &&
(key_info & WPA_KEY_INFO_ENCR_KEY_DATA)) {
+ /*
+ * Only decrypt the Key Data field if the frame's authenticity
+ * was verified. When using AES-SIV (FILS), the MIC flag is not
+ * set, so this check should only be performed if mic_len != 0
+ * which is the case in this code branch.
+ */
+ if (!(key_info & WPA_KEY_INFO_MIC)) {
+ wpa_msg(sm->ctx->msg_ctx, MSG_WARNING,
+ "WPA: Ignore EAPOL-Key with encrypted but unauthenticated data");
+ goto out;
+ }
if (wpa_supplicant_decrypt_key_data(sm, key, ver, key_data,
&key_data_len))
goto out;