summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog9
-rw-r--r--debian/control8
-rw-r--r--debian/patches/2021-1/0001-P2P-Fix-a-corner-case-in-peer-addition-based-on-PD-R.patch50
-rw-r--r--debian/patches/series1
-rw-r--r--src/p2p/p2p_pd.c12
5 files changed, 69 insertions, 11 deletions
diff --git a/debian/changelog b/debian/changelog
index ba86df4..ce704f9 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,12 @@
+wpa (2:2.9.0-21) unstable; urgency=high
+
+ * Fix typos in the package descriptions.
+ Thanks to Beatrice Torracca (Closes: #982673).
+ * SECURITY ISSUE:
+ - P2P: Fix a corner case in peer addition based on PD Request.
+
+ -- Andrej Shadura <andrewsh@debian.org> Thu, 25 Feb 2021 22:19:14 +0100
+
wpa (2:2.9.0-20) unstable; urgency=medium
* Add IgnoreOnIsolate=yes to keep wpa-supplicant running while
diff --git a/debian/control b/debian/control
index 8db2472..4402d78 100644
--- a/debian/control
+++ b/debian/control
@@ -83,7 +83,7 @@ Suggests: wpagui,
Breaks: initscripts (<< 2.88dsf-13.3)
Description: client support for WPA and WPA2 (IEEE 802.11i)
wpa-supplicant is a userspace daemon handling connection and authentication
- in wireless and wired networks, primarily secured with the WPA/WPA/WPA3
+ in wireless and wired networks, primarily secured with the WPA/WPA2/WPA3
protocols. This software provides key negotiation with the access point
(WPA Authenticator), and controls association with IEEE 802.11i networks.
@@ -96,9 +96,9 @@ Depends: ${shlibs:Depends},
${misc:Depends},
busybox-udeb
Package-Type: udeb
-Description: Client support for WPA and WPA2 (IEEE 802.11i)
+Description: client support for WPA and WPA2 (IEEE 802.11i)
wpa-supplicant is a userspace daemon handling connection and authentication
- in wireless and wired networks, primarily secured with the WPA/WPA/WPA3
+ in wireless and wired networks, primarily secured with the WPA/WPA2/WPA3
protocols. This software provides key negotiation with the access point
(WPA Authenticator), and controls association with IEEE 802.11i networks.
.
@@ -123,7 +123,7 @@ Replaces: libwpa-dev
Breaks: libwpa-dev
Description: development files for WPA/WPA2 client support (IEEE 802.11i)
wpa-supplicant is a userspace daemon handling connection and authentication
- in wireless and wired networks, primarily secured with the WPA/WPA/WPA3
+ in wireless and wired networks, primarily secured with the WPA/WPA2/WPA3
protocols. This software provides key negotiation with the access point
(WPA Authenticator), and controls association with IEEE 802.11i networks.
.
diff --git a/debian/patches/2021-1/0001-P2P-Fix-a-corner-case-in-peer-addition-based-on-PD-R.patch b/debian/patches/2021-1/0001-P2P-Fix-a-corner-case-in-peer-addition-based-on-PD-R.patch
new file mode 100644
index 0000000..1942bb3
--- /dev/null
+++ b/debian/patches/2021-1/0001-P2P-Fix-a-corner-case-in-peer-addition-based-on-PD-R.patch
@@ -0,0 +1,50 @@
+From 8460e3230988ef2ec13ce6b69b687e941f6cdb32 Mon Sep 17 00:00:00 2001
+From: Jouni Malinen <jouni@codeaurora.org>
+Date: Tue, 8 Dec 2020 23:52:50 +0200
+Subject: [PATCH] P2P: Fix a corner case in peer addition based on PD Request
+
+p2p_add_device() may remove the oldest entry if there is no room in the
+peer table for a new peer. This would result in any pointer to that
+removed entry becoming stale. A corner case with an invalid PD Request
+frame could result in such a case ending up using (read+write) freed
+memory. This could only by triggered when the peer table has reached its
+maximum size and the PD Request frame is received from the P2P Device
+Address of the oldest remaining entry and the frame has incorrect P2P
+Device Address in the payload.
+
+Fix this by fetching the dev pointer again after having called
+p2p_add_device() so that the stale pointer cannot be used.
+
+Fixes: 17bef1e97a50 ("P2P: Add peer entry based on Provision Discovery Request")
+Signed-off-by: Jouni Malinen <jouni@codeaurora.org>
+---
+ src/p2p/p2p_pd.c | 12 +++++-------
+ 1 file changed, 5 insertions(+), 7 deletions(-)
+
+diff --git a/src/p2p/p2p_pd.c b/src/p2p/p2p_pd.c
+index 3994ec03f86b..05fd593494ef 100644
+--- a/src/p2p/p2p_pd.c
++++ b/src/p2p/p2p_pd.c
+@@ -595,14 +595,12 @@ void p2p_process_prov_disc_req(struct p2p_data *p2p, const u8 *sa,
+ goto out;
+ }
+
++ dev = p2p_get_device(p2p, sa);
+ if (!dev) {
+- dev = p2p_get_device(p2p, sa);
+- if (!dev) {
+- p2p_dbg(p2p,
+- "Provision Discovery device not found "
+- MACSTR, MAC2STR(sa));
+- goto out;
+- }
++ p2p_dbg(p2p,
++ "Provision Discovery device not found "
++ MACSTR, MAC2STR(sa));
++ goto out;
+ }
+ } else if (msg.wfd_subelems) {
+ wpabuf_free(dev->info.wfd_subelems);
+--
+2.25.1
+
diff --git a/debian/patches/series b/debian/patches/series
index 87f00c5..1d4b715 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -33,3 +33,4 @@ upstream-fixes/0015-WPS-Reconfigure-credentials-on-hostapd-config-reload.patch
upstream-fixes/0016-hostapd-Fix-error-message-for-radius_accept_attr-config-option.patch
2020-2/0001-P2P-Fix-copying-of-secondary-device-types-for-P2P-gr.patch
+2021-1/0001-P2P-Fix-a-corner-case-in-peer-addition-based-on-PD-R.patch
diff --git a/src/p2p/p2p_pd.c b/src/p2p/p2p_pd.c
index 3994ec0..05fd593 100644
--- a/src/p2p/p2p_pd.c
+++ b/src/p2p/p2p_pd.c
@@ -595,14 +595,12 @@ void p2p_process_prov_disc_req(struct p2p_data *p2p, const u8 *sa,
goto out;
}
+ dev = p2p_get_device(p2p, sa);
if (!dev) {
- dev = p2p_get_device(p2p, sa);
- if (!dev) {
- p2p_dbg(p2p,
- "Provision Discovery device not found "
- MACSTR, MAC2STR(sa));
- goto out;
- }
+ p2p_dbg(p2p,
+ "Provision Discovery device not found "
+ MACSTR, MAC2STR(sa));
+ goto out;
}
} else if (msg.wfd_subelems) {
wpabuf_free(dev->info.wfd_subelems);