summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/patches/01_remove_asg.patch29
-rw-r--r--debian/patches/03_fix_lib_files.patch51
-rw-r--r--debian/patches/04_fix_manpage.patch12
-rw-r--r--debian/patches/05_fix_string_format.patch27
4 files changed, 79 insertions, 40 deletions
diff --git a/debian/patches/01_remove_asg.patch b/debian/patches/01_remove_asg.patch
index a70ae53..9a9116b 100644
--- a/debian/patches/01_remove_asg.patch
+++ b/debian/patches/01_remove_asg.patch
@@ -1,9 +1,16 @@
Description: Remove ASG from build
Author: Margarita Manterola <marga@debian.org>
---- xcircuit-3.8.78.dfsg.orig/Makefile.in
-+++ xcircuit-3.8.78.dfsg/Makefile.in
-@@ -849,7 +849,6 @@ install-tcl: xcircexec$(EXEEXT) lib/$(IN
+---
+ Makefile.in | 3 ---
+ configure | 7 +++----
+ 2 files changed, 3 insertions(+), 7 deletions(-)
+
+diff --git a/Makefile.in b/Makefile.in
+index f8eef88..2783bf2 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -958,7 +958,6 @@ install-tcl: xcircexec$(EXEEXT) lib/$(INTERP_PATH)/$(WRAPPER_OBJ) lib/$(INTERP_P
clean:
(cd ./Xw; $(RM) *.o *.a *.bak core)
@@ -11,7 +18,7 @@ Author: Margarita Manterola <marga@debian.org>
(cd ./spiceparser; $(MAKE) clean)
$(RM) lib/$(INTERP_PATH)/$(WRAPPER_OBJ) lib/$(INTERP_PATH)/$(WRAPPER_SH)
$(RM) lib/$(INTERP_PATH)/$(WRAPPER_INIT)
-@@ -859,7 +858,6 @@ clean:
+@@ -968,7 +967,6 @@ clean:
distclean:
(cd ./Xw; $(RM) *.o *.a *.bak Makefile core)
@@ -19,7 +26,7 @@ Author: Margarita Manterola <marga@debian.org>
(cd ./spiceparser; $(MAKE) clean ; $(RM) Makefile)
$(RM) xcircuit *.o *.bak core
$(RM) lib/$(INTERP_PATH)/$(WRAPPER_OBJ) lib/$(INTERP_PATH)/$(WRAPPER_SH)
-@@ -879,7 +877,6 @@ dist:
+@@ -988,7 +986,6 @@ dist:
quiteclean:
(cd ./Xw; $(RM) *.o *.a *.bak Makefile.in Makefile core)
@@ -27,9 +34,11 @@ Author: Margarita Manterola <marga@debian.org>
(cd ./spiceparser; $(MAKE) clean ; $(RM) Makefile.in Makefile)
$(RM) xcircuit *.o *.bak core
$(RM) lib/$(INTERP_PATH)/$(WRAPPER_OBJ) lib/$(INTERP_PATH)/$(WRAPPER_SH)
---- xcircuit-3.8.78.dfsg.orig/configure
-+++ xcircuit-3.8.78.dfsg/configure
-@@ -7208,8 +7208,8 @@ if test "${enable_asg+set}" = set; then
+diff --git a/configure b/configure
+index a672b55..e25d697 100755
+--- a/configure
++++ b/configure
+@@ -7371,8 +7371,8 @@ if test "${enable_asg+set}" = set; then :
$as_echo "#define CONFIGURED 1" >>confdefs.h
@@ -40,7 +49,7 @@ Author: Margarita Manterola <marga@debian.org>
fi
-@@ -7571,7 +7571,7 @@ fi
+@@ -7734,7 +7734,7 @@ fi
@@ -49,7 +58,7 @@ Author: Margarita Manterola <marga@debian.org>
cat >confcache <<\_ACEOF
# This file is a shell script that caches the results of configure
-@@ -8321,7 +8321,6 @@ do
+@@ -8480,7 +8480,6 @@ do
"depfiles") CONFIG_COMMANDS="$CONFIG_COMMANDS depfiles" ;;
"Makefile") CONFIG_FILES="$CONFIG_FILES Makefile" ;;
"Xw/Makefile") CONFIG_FILES="$CONFIG_FILES Xw/Makefile" ;;
diff --git a/debian/patches/03_fix_lib_files.patch b/debian/patches/03_fix_lib_files.patch
index 191c4cc..1b3294d 100644
--- a/debian/patches/03_fix_lib_files.patch
+++ b/debian/patches/03_fix_lib_files.patch
@@ -1,9 +1,18 @@
Description: Fix for FHS compliant file locations
Author: Margarita Manterola <marga@debian.org>
---- xcircuit-3.8.78.dfsg.orig/Makefile.am
-+++ xcircuit-3.8.78.dfsg/Makefile.am
-@@ -65,6 +65,9 @@ tmpdir = /tmp
+---
+ Makefile.am | 21 +++++++++++++--------
+ Makefile.in | 28 +++++++++++++++++-----------
+ lib/tcl/xcircuit.sh.in | 4 +++-
+ lib/tcl/xcircuit.tcl.in | 12 +++++++++---
+ 4 files changed, 42 insertions(+), 23 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index f29e863..c82c065 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -34,6 +34,9 @@ tmpdir = /tmp
appdefaultsdir = $(libdir)/$(PACKAGE)-$(VERSION)/app-defaults
appmandir = $(libdir)/$(PACKAGE)-$(VERSION)/man
@@ -13,7 +22,7 @@ Author: Margarita Manterola <marga@debian.org>
PATHNAMES = -DPROG_VERSION=$(VERSION) \
-DPROG_REVISION=$(REVISION) \
-DCAD_DIR=\"$(libdir)\" \
-@@ -146,6 +149,7 @@ CONSOLE_SCRIPT = console.tcl
+@@ -164,6 +167,7 @@ tcl:
lib/$(INTERP_PATH)/$(WRAPPER_SH): lib/$(INTERP_PATH)/$(WRAPPER_SH).in
sed -e '/XCLIBDIR/s#XCLIBDIR#$(librarydir)#' \
@@ -21,7 +30,7 @@ Author: Margarita Manterola <marga@debian.org>
-e '/WRAPPER_INIT/s/WRAPPER_INIT/$(WRAPPER_INIT)/' \
-e '/CONSOLE_SCRIPT/s/CONSOLE_SCRIPT/$(CONSOLE_SCRIPT)/' \
-e '/CONSOLE/s/CONSOLE/$(CONSOLE)/' \
-@@ -157,7 +161,7 @@ lib/$(INTERP_PATH)/$(WRAPPER_SH): lib/$(
+@@ -175,7 +179,7 @@ lib/$(INTERP_PATH)/$(WRAPPER_SH): lib/$(INTERP_PATH)/$(WRAPPER_SH).in
chmod 0755 $@
lib/$(INTERP_PATH)/$(WRAPPER_INIT): lib/$(INTERP_PATH)/$(WRAPPER_INIT).in
@@ -30,7 +39,7 @@ Author: Margarita Manterola <marga@debian.org>
-e '/SCRIPTSDIR/s#SCRIPTSDIR#$(scriptsdir)#' \
lib/$(INTERP_PATH)/$(WRAPPER_INIT).in > $@
chmod 0755 $@
-@@ -211,19 +215,20 @@ install-tcl: xcircexec$(EXEEXT) lib/$(IN
+@@ -229,19 +233,20 @@ install-tcl: xcircexec$(EXEEXT) lib/$(INTERP_PATH)/$(WRAPPER_OBJ) lib/$(INTERP_P
@echo "Installing standard XCircuit library files"
$(MAKE) $(AM_MAKEFLAGS) install-data-local
@echo "Installing Tcl files"
@@ -58,9 +67,11 @@ Author: Margarita Manterola <marga@debian.org>
$(RM) $(WRAPPER_SO) ; \
ln -s $(WRAPPER_OBJ) $(WRAPPER_SO) ) ; \
fi
---- xcircuit-3.8.78.dfsg.orig/Makefile.in
-+++ xcircuit-3.8.78.dfsg/Makefile.in
-@@ -264,9 +264,6 @@ ac_aux_dir = dist
+diff --git a/Makefile.in b/Makefile.in
+index 2783bf2..40c5414 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -371,9 +371,6 @@ ac_aux_dir = dist
# Temporary directory (if not overridden by environment variable TMPDIR)
tmpdir = /tmp
@@ -70,7 +81,7 @@ Author: Margarita Manterola <marga@debian.org>
PATHNAMES = -DPROG_VERSION=$(VERSION) \
-DPROG_REVISION=$(REVISION) \
-DCAD_DIR=\"$(libdir)\" \
-@@ -297,6 +294,13 @@ M4_DEFS = @M4_DEFS@ @DEFS@
+@@ -408,6 +405,13 @@ M4_DEFS = @M4_DEFS@ @DEFS@
man_MANS = lib/xcircuit.1
INCLUDES = -IXw ${INC_SPECS}
@@ -84,7 +95,7 @@ Author: Margarita Manterola <marga@debian.org>
# Library directory and files
librarydir = $(libdir)/$(PACKAGE)-$(VERSION)
scriptsdir = $(libdir)/$(PACKAGE)-$(VERSION)
-@@ -755,6 +759,7 @@ xtfuncs.c: menudep.h
+@@ -864,6 +868,7 @@ tcl:
lib/$(INTERP_PATH)/$(WRAPPER_SH): lib/$(INTERP_PATH)/$(WRAPPER_SH).in
sed -e '/XCLIBDIR/s#XCLIBDIR#$(librarydir)#' \
@@ -92,7 +103,7 @@ Author: Margarita Manterola <marga@debian.org>
-e '/WRAPPER_INIT/s/WRAPPER_INIT/$(WRAPPER_INIT)/' \
-e '/CONSOLE_SCRIPT/s/CONSOLE_SCRIPT/$(CONSOLE_SCRIPT)/' \
-e '/CONSOLE/s/CONSOLE/$(CONSOLE)/' \
-@@ -766,7 +771,7 @@ lib/$(INTERP_PATH)/$(WRAPPER_SH): lib/$(
+@@ -875,7 +880,7 @@ lib/$(INTERP_PATH)/$(WRAPPER_SH): lib/$(INTERP_PATH)/$(WRAPPER_SH).in
chmod 0755 $@
lib/$(INTERP_PATH)/$(WRAPPER_INIT): lib/$(INTERP_PATH)/$(WRAPPER_INIT).in
@@ -101,7 +112,7 @@ Author: Margarita Manterola <marga@debian.org>
-e '/SCRIPTSDIR/s#SCRIPTSDIR#$(scriptsdir)#' \
lib/$(INTERP_PATH)/$(WRAPPER_INIT).in > $@
chmod 0755 $@
-@@ -820,19 +825,20 @@ install-tcl: xcircexec$(EXEEXT) lib/$(IN
+@@ -929,19 +934,20 @@ install-tcl: xcircexec$(EXEEXT) lib/$(INTERP_PATH)/$(WRAPPER_OBJ) lib/$(INTERP_P
@echo "Installing standard XCircuit library files"
$(MAKE) $(AM_MAKEFLAGS) install-data-local
@echo "Installing Tcl files"
@@ -129,8 +140,10 @@ Author: Margarita Manterola <marga@debian.org>
$(RM) $(WRAPPER_SO) ; \
ln -s $(WRAPPER_OBJ) $(WRAPPER_SO) ) ; \
fi
---- xcircuit-3.8.78.dfsg.orig/lib/tcl/xcircuit.sh.in
-+++ xcircuit-3.8.78.dfsg/lib/tcl/xcircuit.sh.in
+diff --git a/lib/tcl/xcircuit.sh.in b/lib/tcl/xcircuit.sh.in
+index d9800c2..d22bb6c 100755
+--- a/lib/tcl/xcircuit.sh.in
++++ b/lib/tcl/xcircuit.sh.in
@@ -6,7 +6,9 @@
#
@@ -149,8 +162,10 @@ Author: Margarita Manterola <marga@debian.org>
+ exec ${exelibdir}/xcircexec -- $@
fi
---- xcircuit-3.8.78.dfsg.orig/lib/tcl/xcircuit.tcl.in
-+++ xcircuit-3.8.78.dfsg/lib/tcl/xcircuit.tcl.in
+diff --git a/lib/tcl/xcircuit.tcl.in b/lib/tcl/xcircuit.tcl.in
+index 5eee0d6..db44646 100755
+--- a/lib/tcl/xcircuit.tcl.in
++++ b/lib/tcl/xcircuit.tcl.in
@@ -12,6 +12,11 @@ if {$envlibdir == {}} {
}
unset envlibdir
@@ -163,7 +178,7 @@ Author: Margarita Manterola <marga@debian.org>
set envsrcdir [array get env "XCIRCUIT_SRC_DIR"]
if {$envsrcdir != {}} {
set path [lindex $envsrcdir 1]
-@@ -28,13 +33,14 @@ if {[string compare $tcl_platform(platfo
+@@ -28,13 +33,14 @@ if {[string compare $tcl_platform(platform) "windows"] == 0} {
}
set tcllibdir $path
diff --git a/debian/patches/04_fix_manpage.patch b/debian/patches/04_fix_manpage.patch
index 4ed05c4..2845eab 100644
--- a/debian/patches/04_fix_manpage.patch
+++ b/debian/patches/04_fix_manpage.patch
@@ -2,9 +2,15 @@ Description: Manpage fix
This patch fixes a format problem in a table in the manpage
Author: Roland Stigge <stigge@antcom.de>
---- xcircuit-3.8.78.dfsg.orig/lib/xcircuit.1.in
-+++ xcircuit-3.8.78.dfsg/lib/xcircuit.1.in
-@@ -1042,89 +1042,89 @@ follows, with their default values given
+---
+ lib/xcircuit.1.in | 166 +++++++++++++++++++++++++++---------------------------
+ 1 file changed, 83 insertions(+), 83 deletions(-)
+
+diff --git a/lib/xcircuit.1.in b/lib/xcircuit.1.in
+index b59b986..d579905 100644
+--- a/lib/xcircuit.1.in
++++ b/lib/xcircuit.1.in
+@@ -1042,89 +1042,89 @@ follows, with their default values given:
.br
.sp
diff --git a/debian/patches/05_fix_string_format.patch b/debian/patches/05_fix_string_format.patch
index d902ff7..c3bd053 100644
--- a/debian/patches/05_fix_string_format.patch
+++ b/debian/patches/05_fix_string_format.patch
@@ -3,9 +3,16 @@ Description: Fix sprintf() format strings
patch adds them.
Author: Roland Stigge <stigge@antcom.de>
---- xcircuit-3.8.78.dfsg.orig/svg.c
-+++ xcircuit-3.8.78.dfsg/svg.c
-@@ -1109,12 +1109,12 @@ int xctcl_svg(ClientData clientData, Tcl
+---
+ svg.c | 6 +++---
+ tclxcircuit.c | 8 ++++----
+ 2 files changed, 7 insertions(+), 7 deletions(-)
+
+diff --git a/svg.c b/svg.c
+index 3b155d1..5375cea 100644
+--- a/svg.c
++++ b/svg.c
+@@ -1133,12 +1133,12 @@ int xctcl_svg(ClientData clientData, Tcl_Interp *interp,
if (locobjc >= 2) {
/* If there is a non-option argument, use it for the output filename */
@@ -21,9 +28,11 @@ Author: Roland Stigge <stigge@antcom.de>
pptr = strrchr(filename, '.');
if (pptr != NULL)
---- xcircuit-3.8.78.dfsg.orig/tclxcircuit.c
-+++ xcircuit-3.8.78.dfsg/tclxcircuit.c
-@@ -3857,7 +3857,7 @@ int xctcl_object(ClientData clientData,
+diff --git a/tclxcircuit.c b/tclxcircuit.c
+index 6e49bba..62514d2 100644
+--- a/tclxcircuit.c
++++ b/tclxcircuit.c
+@@ -3876,7 +3876,7 @@ int xctcl_object(ClientData clientData, Tcl_Interp *interp,
case NameIdx:
if (nidx == 1 || areawin->selects == 0) {
if (objc == 3) {
@@ -32,7 +41,7 @@ Author: Roland Stigge <stigge@antcom.de>
checkname(thisinst->thisobject);
}
Tcl_AppendElement(interp, thisinst->thisobject->name);
-@@ -7267,7 +7267,7 @@ int xctcl_page(ClientData clientData, Tc
+@@ -7356,7 +7356,7 @@ int xctcl_page(ClientData clientData, Tcl_Interp *interp,
case LoadIdx:
TechReplaceSave();
@@ -41,7 +50,7 @@ Author: Roland Stigge <stigge@antcom.de>
for (i = 3 + nidx; i < objc; i++) {
argv = Tcl_GetString(objv[i]);
if ((*argv == '-') && !strncmp(argv, "-repl", 5)) {
-@@ -7353,7 +7353,7 @@ int xctcl_page(ClientData clientData, Tc
+@@ -7442,7 +7442,7 @@ int xctcl_page(ClientData clientData, Tcl_Interp *interp,
switch (importtype) {
case XCircuitIdx:
@@ -50,7 +59,7 @@ Author: Roland Stigge <stigge@antcom.de>
for (i = 4; i < objc; i++) {
strcat(_STR2, ",");
strcat(_STR2, Tcl_GetString(objv[i + nidx]));
-@@ -7370,7 +7370,7 @@ int xctcl_page(ClientData clientData, Tc
+@@ -7459,7 +7459,7 @@ int xctcl_page(ClientData clientData, Tcl_Interp *interp,
Tcl_SetObjResult(interp, objPtr);
return XcTagCallback(interp, objc, objv);
}