summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules22
1 files changed, 0 insertions, 22 deletions
diff --git a/debian/rules b/debian/rules
index 92e77c7..577e2fc 100755
--- a/debian/rules
+++ b/debian/rules
@@ -9,15 +9,6 @@ DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
dh $@ --with autoreconf
override_dh_auto_configure:
- cp -f /usr/share/misc/config.sub config.sub
- cp -f /usr/share/misc/config.guess config.guess
- # Some touch-fu
- touch --time=mtime -r configure.in Makefile.am
- touch --time=mtime -r configure.in Makefile.in
- touch --time=mtime -r configure.in configure
- touch --time=mtime -r configure.in aclocal.m4
- touch --time=mtime -r configure.in Xw/Makefile.am
- touch --time=mtime -r Xw/Makefile.am Xw/Makefile.in
dh_auto_configure -- --x-includes=/usr --with-tcl=/usr/lib \
--with-tcllibs=/usr/lib/$(DEB_HOST_MULTIARCH) \
--with-tklibs=/usr/lib/$(DEB_HOST_MULTIARCH)
@@ -46,16 +37,3 @@ override_dh_compress:
dh_compress --exclude examples/
override_dh_auto_test:
-
-TMP=get-orig-source-tmp
-get-orig-source:
- rm -rf $(TMP)
- mkdir $(TMP)
- uscan --download --no-symlink --destdir $(TMP)
- cd $(TMP) && tar xf xcircuit*.tgz && \
- rm xcircuit*.tgz && \
- rm -r */asg && \
- rm -f */spiceparser/example && \
- VERSION=`ls -d xcircuit*` && \
- tar cfj ../$$VERSION.dfsg.tar.bz2 $$VERSION
- rm -rf $(TMP)