summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorGeorges Basile Stavracas Neto <georges.stavracas@gmail.com>2023-07-15 10:34:38 -0300
committerGeorges Basile Stavracas Neto <GeorgesStavracas@users.noreply.github.com>2023-07-15 16:15:46 -0300
commit61a8cc080a3d86207348e77bd8e9e91d52332e34 (patch)
treefd5239bdfc26bf93bc7eae4c1fa7a56e8eb084cc /meson.build
parent35d307c7f2ab793541611ec6a2db331477dd6477 (diff)
Make PipeWire dependency mandatory
PipeWire has solidified its position in the Linux world over the last few years, and nowadays pretty much all relevant Linux distributions ship PipeWire 0.3. Make the PipeWire dependency required.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 1 insertions, 9 deletions
diff --git a/meson.build b/meson.build
index ee1fafd..b25f9ef 100644
--- a/meson.build
+++ b/meson.build
@@ -110,9 +110,7 @@ geoclue_dep = dependency('libgeoclue-2.0',
required: get_option('geoclue'))
libportal_dep = dependency('libportal',
required: get_option('libportal'))
-pipewire_dep = dependency('libpipewire-0.3',
- version: '>= 0.2.90',
- required: get_option('pipewire'))
+pipewire_dep = dependency('libpipewire-0.3', version: '>= 0.2.90')
libsystemd_dep = dependency('libsystemd', required: get_option('systemd'))
bwrap_required = host_machine.system() in ['linux']
@@ -128,11 +126,6 @@ if have_geoclue
config_h.set('HAVE_GEOCLUE', 1)
endif
-have_pipewire = pipewire_dep.found()
-if have_pipewire
- config_h.set('HAVE_PIPEWIRE', 1)
-endif
-
have_libsystemd = libsystemd_dep.found()
if have_libsystemd
config_h.set('HAVE_LIBSYSTEMD', 1)
@@ -189,7 +182,6 @@ configure_file(output: 'config.h', configuration: config_h)
summary({
'Enable docbook documentation': build_docbook,
- 'Enable pipewire support': have_pipewire,
'Enable libsystemd support': have_libsystemd,
'Enable geoclue support': have_geoclue,
'Enable libportal support': have_libportal,