summaryrefslogtreecommitdiff
path: root/ChangeLog
diff options
context:
space:
mode:
Diffstat (limited to 'ChangeLog')
-rw-r--r--ChangeLog178
1 files changed, 178 insertions, 0 deletions
diff --git a/ChangeLog b/ChangeLog
index ba945aa..aae6f20 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,181 @@
+2009-12-24 karl <charcoal@users.sf.net>
+
+ * 3.1.2 release.
+ * updates to src/gnome2/Makefile.am: distribution tarball sanity.
+
+2009-12-19 karl <charcoal@users.sf.net>
+
+ * change freenode webchat to use $USER (g_get_user_name()).
+
+2009-12-14 karl <charcoal@users.sf.net>
+
+ * preferences locale list: display language names, not xx_YY.
+ * fixed <div align=(right|left)> problem.
+
+2009-12-14 simon<DrMeers@users.sourceforge.net>
+
+ * fixed tab bug -- closing tab B focused tab A, but cur_passage_tab
+ got set to tab C!
+
+2009-12-04 simon<DrMeers@users.sourceforge.net>
+
+ * fixed window title bug -- changing modules in the sidebar treeview
+ updated window title to _previous_ module, because
+ gui_change_window_title used tab settings prior to update
+
+2009-12-04 matthew<ransom1982@users.sourceforge.net>
+ simon<DrMeers@users.sourceforge.net>
+
+ * new book icons for module list to better match colors
+ * improved rendering for icons
+ * rtol icons for module lists
+
+2009-12-04 matthew<ransom1982@users.sourceforge.net>
+
+ * de-gnome menus and as many other functions as possible
+ * add option to waf to build without gnome
+
+2009-12-02 matthew<ransom1982@users.sourceforge.net>
+
+ * removed display_mgr from backend
+ * delay starting search backend
+
+2009-11-28 matthew<ransom1982@users.sourceforge.net>
+
+ * added code to use libgsf to archive files
+ * small improvements to Windows file finding
+ * module manager optimizations
+
+2009-11-18 terry <tbiggs@users.sourceforge.net>
+
+ *added search results and verse lists to exporter
+
+2009-11-12 karl <charcoal@users.sf.net>
+
+ * improve search word color marking slightly, so that wildcard-
+ matched roots get colored.
+
+2009-11-10 terry <tbiggs@users.sourceforge.net>
+
+ * add bookmark exporter.
+
+2009-11-04 karl <charcoal@users.sf.net>
+
+ * Ensure mod.mgr always has a proper icon.
+
+2009-10-27 karl <charcoal@users.sf.net>
+
+ * Resurrect verse number color selector in preferences.
+ Also removed some defunct enums, unused for years.
+
+2009-09-30 karl <charcoal@users.sf.net>
+
+ * add gui_init() calls to settings_init() to ensure that gnome/gtk
+ are ready if we should need any dialogs.
+ * add static status variable to gui_init() so it happens just once.
+
+2009-09-21 matthew<ransom1982@users.sourceforge.net>
+
+ * change Windows to use ShellExecuteW instead of gnome_show_url
+ * new function xiphos_open_default to open anything on any platform
+ * change help menu to point to new location for chm files on Windows
+ * added linkbutton hook so that linkbuttons (in about dialogs) would
+ work on Windows
+
+2009-09-21 karl <charcoal@users.sf.net>
+
+ * move gconf_setup() to gui_init() where it belongs.
+
+2009-09-12 karl <charcoal@users.sf.net>
+
+ * feat.req #2813476 Interface localization (prefs->options)
+
+2009-09-06 karl <charcoal@users.sf.net>
+
+ * correct re-appearing remote ftp source for delete-then-load-standard.
+ * fix #2825898 Search triggers show-up of markers in Preview
+ (by accurately detecting within/without html constructs).
+ * consequently removed <a></a> elimination code as well.
+ * corrected gtk store error for prayerlist (lacking -1 terminator).
+ * avoid widget destroy whine for null widget.
+ * fix #2813891 lose comm name from tab when un-Viewed.
+ * address #2798255 with a manual update.
+ * also mention Load Standard button for module manager.
+ * fix #2797805 added a word: Show/Hide _Attached_ Sidebar.
+ * feat.req.#2190241 add Enter key support for bookmarks,
+ annotations, mod.mgr remote sources.
+ * feat.req #2797789 Open pane for activated resource (sidebar.cc)
+
+2009-09-05 karl <charcoal@users.sf.net>
+
+ * 2nd shot at CrossWire as default remote repo, requiring rather a
+ lot of other code re-factoring due to the interdependence of the
+ 1st-time user's mod.mgr vis-a-vis existence of settings.xml data.
+
+2009-09-03 karl <charcoal@users.sf.net>
+
+ * add intro dialog box to first-time mod.mgr usage.
+ * re-work the entire locale-setting mechanism.
+ * force CrossWire as default remote repo after load-standard.
+
+2009-09-01 karl <charcoal@users.sf.net>
+
+ * fix #2841441 per verse annotation - localized reference
+ * implied a bunch of other stuff:
+ - convert <markedverses> to <osisrefmarkedverses> on init.
+ - move locale init inside backend ctor.
+ - localize *u refs for previewer, per bug report.
+ - parse in osisref form.
+ - dispose of bogus ".xiphos-2.0" dir rename (historic from
+ very old .gnomesword-2.0 needs).
+
+2009-08-31 karl <charcoal@users.sf.net>
+
+ * remove devotionals from "lookup selection" menus.
+ * correct null key pointer in sword.cc debug message.
+
+2009-08-21 karl <charcoal@users.sf.net>
+
+ * ensure a bit of whitespace between strong's elements when
+ they repeat. they can get bunched up on top of each other
+ too easily.
+ * fix another blocking nightmare: some modules (ABP) contain
+ bogus sequences like <seg><hi><seg><hi>word</hi></seg></hi></seg>.
+ this results in doubling, <i><i>word</i></i>. the block
+ renderer gets unhappy when it mis-analyzes termination by
+ finding the inner </i> as though it were the termination of
+ the outer <i>. so if we find we have an internal set of
+ <i></i>, we simply wipe them to spaces, and try again.
+ ugh.
+ * apply patch by andrew anderson, to respect showversenum in the
+ passage exporter. some additional mods beyond his basic patch.
+
+2009-08-20 matthew <ransom1982@users.sourceforge.net>
+
+ * fix #2825281 Sidebar/Regular Expression search: not finding all matches
+
+2009-08-17 karl <charcoal@users.sf.net>
+
+ * change main window title per actually-displayed modules.
+ (echoes tab module choice; borrows same code.)
+
+2009-08-15 karl <charcoal@users.sf.net>
+
+ * fix #2803614 Search in unpointed Hebrew not working, by ensuring
+ that all vowel points & accents are turned off in modules and
+ search strings.
+
+2009-08-13 karl <charcoal@users.sf.net>
+
+ * implemented glib null string detection skeleton. enabled as part of DEBUG.
+
+2009-08-10 terry <tbiggs@users.sourceforge.net>
+
+ * added ui/editor_link_dialog.xml, editor/link_dialog.c and
+ editor/link_dialog.h
+ * added New menu item and button to studypad (slib-editor)
+ * added Delete menu item and button to note editor (slib-editor)
+
2009-08-09 karl <charcoal@users.sf.net>
* 3.1.1 release.